Jump to content
j3rry

Crash in #98 opening HSL dialog on non retina screen (split)

Recommended Posts

Activating the HSL Dialog crash the beta immediately, so its useless for me because i use HSL very often. Also the DXO-Nik Plugins dont working, but they work since the DXO Update from today with the 1.6.x Version. All on MACOSX Mojave.


 


Affinity Photo & Designer & DxO Photolab on a Macbook Pro (2014) 16gb Ram, 512 GB SSD, Eizo CS240, MacOSX Mojave

Share this post


Link to post
Share on other sites
2 minutes ago, j3rry said:

Activating the HSL Dialog crash the beta immediately, so its useless for me because i use HSL very often. Also the DXO-Nik Plugins dont working, but they work since the DXO Update from today with the 1.6.x Version. All on MACOSX Mojave.


 

No problems on my side with the HSL dialog. It must be a combination of things. I'm also running Mojave. 

Screenshot 2018-11-14 at 22.47.23.png

Share this post


Link to post
Share on other sites
32 minutes ago, Andy Somerfield said:

j3rry,

Are you using Photo on a Retina display, or a non-retina display (or external screen) when the crash happens with HSL? We have been tracking a potential crash on non-retina screens, but have been unable to reproduce..

Thanks,

A

I use a MacBook Pro (Retina, 15', Mitte 2014) and it will not crash on the MBP Display only on the second (non-retina) EIZO Monitor which is my main display.

Even moving the HSL dialog from Retina display to the non-retina display crashed AP immediately.


Affinity Photo & Designer & DxO Photolab on a Macbook Pro (2014) 16gb Ram, 512 GB SSD, Eizo CS240, MacOSX Mojave

Share this post


Link to post
Share on other sites

j3rry,

 

Ok, thanks. This should not be happening then..

If possible could you give a full description of your system (specific hardware, and more importantly, specific version of macOS) - our QA guys will pick this up in the morning and hopefully reproduce.

It would be good to reproduce this, we have heard reports of it before..

 

Thanks,

 

A

Share this post


Link to post
Share on other sites
21 minutes ago, Andy Somerfield said:

j3rry,

 

Ok, thanks. This should not be happening then..

If possible could you give a full description of your system (specific hardware, and more importantly, specific version of macOS) - our QA guys will pick this up in the morning and hopefully reproduce.

It would be good to reproduce this, we have heard reports of it before..

 

Thanks,

 

A

Nothing special with my MBP, only a EIZO CS240 as external monitor and a Wacom pad.

Überblick über die Systemsoftware:

  Systemversion: macOS 10.14.1 (18B75)

  Kernel-Version: Darwin 18.2.0

  Startvolume: Macintosh HD

  Startmodus: Normal

  Sicherer virtueller Speicher: Aktiviert

  Systemintegritätsschutz: Aktiviert

  Zeit seit dem Start: 3 Tage 4:58

Hardware-Übersicht:

  Modellname: MacBook Pro

  Modell-Identifizierung: MacBookPro11,3

  Prozessortyp: Intel Core i7

  Prozessorgeschwindigkeit: 2,5 GHz

  Anzahl der Prozessoren: 1

  Gesamtanzahl der Kerne: 4

  L2-Cache (pro Kern): 256 KB

  L3-Cache: 6 MB

  Speicher: 16 GB

  Boot-ROM-Version: 149.0.0.0.0

  SMC-Version (System): 2.19f12

 

If its helpful the graphic here is:

 

NVIDIA GeForce GT 750M:

  Chipsatz-Modell: NVIDIA GeForce GT 750M

  Typ: GPU

  Bus: PCIe

  PCIe-Lane-Breite: x8

  VRAM (dynamisch, maximal): 2048 MB

  Hersteller: NVIDIA (0x10de)

  Geräte-ID: 0x0fe9

  Versions-ID: 0x00a2

  ROM-Version: 3776

  Automatischer Wechsel der Grafikmodi: Unterstützt

  gMux-Version: 4.0.8 [3.2.8]

  Metal: Unterstützt, Funktionsset macOS GPUFamily1 v4

  Displays:

Farb-LCD:

  Displaytyp: Integriertes Retina-LCD-Display

  Auflösung: 2880 x 1800 Retina

  Framepuffertiefe: 24-Bit Farbe (ARGB8888)

  Synchronisierung: Aus

  Eingeschaltet: Ja

  Rotation: Unterstützt

  Helligkeit automatisch anpassen: Nein

CS240:

  Auflösung: 1920 x 1200 (WUXGA - Widescreen Ultra eXtended Graphics Array)

  UI sieht aus wie: 1920 x 1200

  Framepuffertiefe: 24-Bit Farbe (ARGB8888)

  Hauptdisplay: Ja

  Synchronisierung: Aus

  Eingeschaltet: Ja

  Rotation: Unterstützt

  Helligkeit automatisch anpassen: Nein

  Verbindungstyp: DisplayPort

 

I've attached a complete crashreport.

Crash_ap_beta.txt


Affinity Photo & Designer & DxO Photolab on a Macbook Pro (2014) 16gb Ram, 512 GB SSD, Eizo CS240, MacOSX Mojave

Share this post


Link to post
Share on other sites

It must be an init problem, starting on an retina display works even i move the beta to my eizo. I can open and work with the HSL dialog. Closing the file and open again on the non-retina display crashes the beta.


Affinity Photo & Designer & DxO Photolab on a Macbook Pro (2014) 16gb Ram, 512 GB SSD, Eizo CS240, MacOSX Mojave

Share this post


Link to post
Share on other sites

With version 1.7.0.100 HSL dont crash anymore and my short test shows that HSL is working. Congrats  and thanks.


Affinity Photo & Designer & DxO Photolab on a Macbook Pro (2014) 16gb Ram, 512 GB SSD, Eizo CS240, MacOSX Mojave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×