Jump to content

Recommended Posts


In both Affinity Designer as well as, I cannot currently open any file, or even start a new document, without the application crashing. 

This is obviously really annoying as I have started a small project using the software, which worked fine, but now I have no possibility of accessing the saved file(s). I don't really understand what has changed. I have tried uninstalling and re-installing the application, to no avail. The problem first occurred after leaving the software open through a hibernation of Windows. 

This is on Windows 10 Pro build 17134. Detailed hardware info attached in second attachment.

The error message is:

"An Unhandled Exception has occurred and the application cannot continue. The Crash Reporter will be displayed after the application exits. Reference: 833df4fb-9734-43a9-8c26-a0cd1f3da7ea"

(screenshot attached). As shown in the screenshot, the application shows the file as loaded to 100 %, but no part of the file is displayed yet. The same happens when clicking on New Document on the startup panel, and then pressing ok on the default settings in the New Document settings dialogue (after a very short flicker, the same message as shown in the screenshot appears, with a different reference obviously).

For what it's worth, Affinity Photo appears to still work fine.

Any help is appreciated.





Share this post

Link to post
Share on other sites

Hi jhzg,

Welcome to the forums :)

Could you please provide me with your log files from %APPDATA%\Affinity\Designer\1.0\CrashReports?

Please double check that your GPU drivers are up to date, as this is usually what causes crashing within Affinity when leading documents.

Share this post

Link to post
Share on other sites

Thank you for the response. 

I have updated my graphics driver to 

Version: R375 U9 (377.55)  WHQL
Release Date: 2017.7.24
Operating System: Windows 10 64-bit
Language: English (UK)

(was 369.09).

So far, this has not helped, but I will keep investigating in that direction.

A crash report is attached.



Share this post

Link to post
Share on other sites

Thank you for that, I'll forward the crash log for our developers to investigate :)

In the meantime, could you please open %APPDATA%\Affinity\Designer\ and rename the 1.0 folder to 1.0_Backup (Affinity Designer will need to be closed).

Once this has been done, please open the app, does it crash at the same place?

Share this post

Link to post
Share on other sites

@Dan C Renaming the 1.0 directory has solved the issue! Thank you very much for your help.


@Mark Ingram Interesting. Log.txt attached. 

The preferences with a blank 1.0 directory (reset to defaults I guess) are different than what I have if I restore the backup 1.0 directory.

The settings with the old (crashing) 1.0 dir.:


Settings after reset (no crash):

It definitely looks like something has gone wrong there.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.