Jump to content
Tyree

"Touch for gestures only" setting broken in current version of Affinity Photo for iPad

Recommended Posts

Hi.

I appears that the touch for gestures feature is broken in the current version of Affinity Photo for iPad.  I've had stray red marks appear from my palm or from trying to move the canvas with my finger while using the healing brush with my Apple Pencil.  Sadly I did not notice one of these marks until after I had made a large number of edits.  The mistake was ~180 changes back in the undo history.  Unless there is a way to remove a single edit from the undo history, I've wasted a lot of time because of this bug.  As I tend to do quite a bit of cleaning up of my photos, this bug lowers my confidence in the product so far as to not being able to use it at all.  :-(

Tyree

 

Share this post


Link to post
Share on other sites

Hi Tyree,

Unfortunately there was an intentional change by development that made 'Touch for gestures only' work on some brushes , but has proved very unpopular! Was it the Inpainting Tool you were using? That ignores 'Touch for gestures only', and is likely to leave red marks from the overlay. However the Healing Brush Tool adheres to the 'Touch for gestures only' setting and doesn't leave any red marks.

Either way I have passed your comments back to them - thank you for letting us know!

Share this post


Link to post
Share on other sites

Hi Sean, the inpainting tool bug was reported extensively a while ago, screen recordings etc, and that bug leaves permanent red marks on the layer too. Perhaps this is linked?

 


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

Lasso selections also ignore 'Touch for gestures only' leading to selections closing early, new selections starting randomly, having to redo them, etc., etc.,  Universally, this intentional change has caused me nothing but significant delays.  

Share this post


Link to post
Share on other sites
On 11/9/2018 at 3:29 AM, Sean P said:

Hi Tyree,

Unfortunately there was an intentional change by development that made 'Touch for gestures only' work on some brushes , but has proved very unpopular! Was it the Inpainting Tool you were using? That ignores 'Touch for gestures only', and is likely to leave red marks from the overlay. However the Healing Brush Tool adheres to the 'Touch for gestures only' setting and doesn't leave any red marks.

Either way I have passed your comments back to them - thank you for letting us know!

You are right.  I mistakingly said it was the healing brush when it was in fact the Inpainting tool.  Regardless, I now have to go back to using the desktop app, which tethers me to my desk instead of having the freedom to do my edits in the company of my family and friends.

 

On the upside this shows just how powerful a proposition the iPad version of this tool is. On the downside it demonstrates the need for the extraordinary care that should be taken before making changes to the user interface.  Is there a beta program for the iPad version where you all can receive feedback before releasing a new version?  Also, is there anyway that we can revert back to the previous version?

 

Additionally, while I greatly appreciate the fact that you all are not doing a subscription model, I do expect that you should eventually have new major versions to purchase to ensure that you all are able to remain viable financially speaking.  If there will be new major versions, will you publish a roadmap so that we users can plan ahead?

Share this post


Link to post
Share on other sites
39 minutes ago, Tyree said:

Is there a beta program for the iPad version where you all can receive feedback before releasing a new version?

 


Alfred online2long.gif
Affinity Designer 1.7.0.367 • Affinity Photo 1.7.0.367 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.0.135 • Affinity Designer for iPad 1.7.0.9 • iOS 12.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

The beta version via TestFlight fixed the issue, I thought that the update also fixed but not. I deleted the beta, installed the update, how silly me!

Share this post


Link to post
Share on other sites

In the last few updates I really hoped that this bug would be resolved, but unfortunately it's still there.

Is there any chance that sooner or later the developers will fix this really annoying problem?

Please, let me know.

Share this post


Link to post
Share on other sites

I'm just checking to see if there are any plans to fix this bug?  I've had no choice but to stop using Affinity Photo for most of my work over this one bug.  :-(

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×