Jump to content
StuartRc

Intermittent issues with drawing tools [Pen+Pencil]

Recommended Posts

Hi

I have a couple of queries regarding the drawing tools (1.7)

A Use of the pencil tool is not always following the track of the Wacom Pen seems to intermittently fail (Not sure what starts/causes it!)... I noticed this..  was present in the previous Beta

Steps to reproduce:
1 Create new page

2. Select Pencil Tool or Pen Tool on new page (Snapping is OFF)..initially had several docs open including the sample brochure

3. Draw on new Page until occurs (Controller set to NONE + stabiliser ON or OFF)

Occasionally the pencil starts to revert to linear lines between 2 points...not necessarily on the track of the pen

4. Close and Restart APP fixes issue
 

B When you select the Pen tool+'Construction Snapping' sometimes the construction options are not visible. Select >Perform Construction Snapping...(aware Ben implied these tools may not reach  final version)There will be a delay and then the options appear. Once icons present issue resolved (even between tool selection)

NB:Construction snapping options appear after pen selected and click for first node

C. Pen Selected + Pen Mode + add nodes to page +there can be a delay in adding the line connecting the latest line

 

 

 

 


APh & AD 1.7.1.445 + Beta AD 1.7.2.464 | APh 1.7.1.404 + Beta AP 1.7.2.464
APu 1.7.1.404 +Beta Apu 1.7.2.458

OS:Windows 10 Pro 1903 OS Build 18362.295
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 19.08.1(Adrenalin, 
Radeon Settings Version
19.1.1) + Wacom Intuous 4M with driver 6.3.35-3

 

 

Share this post


Link to post
Share on other sites

Hi StuartRc,

A. How long drawing do you find it takes before this issue crops up? I've just tried it myself and have not been able to reproduce it. Are you able to record a video showing this at all?
B. This is a known issue that we have reported and has been passed on to development.
C. Again I've not noticed this - are you able to record a video showing this as well?

Thanks!

Share this post


Link to post
Share on other sites
On 11/5/2018 at 11:43 AM, Sean P said:

Hi StuartRc,

A. How long drawing do you find it takes before this issue crops up? I've just tried it myself and have not been able to reproduce it. Are you able to record a video showing this at all?
B. This is a known issue that we have reported and has been passed on to development.
C. Again I've not noticed this - are you able to record a video showing this as well?

Thanks!

Thanks for getting back to me

Sorry I missed your reply...O.o...been busy with Inktober..even though it's November!

A: Good question it tends to vary...but I did notice that if you leave the app alone for a short period of time...it can just start happening. I tried mixing up the settings (Sculpt/Controller/Stabilizer) to see if could pin it down!..but seemed to occur just after a period of time. I can get the tools to work initially...then say the pencil tool..drawing a wavy line..actually returns a linear line between 2 obscure nodes..I have not tried latest beta yet..but will

B:OK...least not just me:)

C: Added video of of events..

Notes:

On the video in the first part I was drawing a wavy line (2pt black)...not that it was showing up!...then just connected 2 unrelated nodes.

Most of video to do with changing pen/pencil function/settings to see what results are

I have not seen this prior to the .157 beta release..again have not checked with latest....hopefully it it is an isolated set of issues.

Seems to be OK in .162...so far

 


APh & AD 1.7.1.445 + Beta AD 1.7.2.464 | APh 1.7.1.404 + Beta AP 1.7.2.464
APu 1.7.1.404 +Beta Apu 1.7.2.458

OS:Windows 10 Pro 1903 OS Build 18362.295
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 19.08.1(Adrenalin, 
Radeon Settings Version
19.1.1) + Wacom Intuous 4M with driver 6.3.35-3

 

 

Share this post


Link to post
Share on other sites

Hi StuartRc,

Sorry for the delay! We've recently got a new Intuos Pro in the office and after seeing your other messages in a couple of other posts, I've poked this again using the 6.3.31-4 drivers and have been able to reproduce it.

It seems to happen if I change window focus by going to Outlook and on returning to Designer it is 'stuck' drawing lines! 

I'll get this passed on to development!

Thanks again for your help :)

 

Share this post


Link to post
Share on other sites

Delay...not a problem I was beginning to think it was just me.....again!:)...just reported the bug and moved on...was not expecting an immediate fix.......I was relieved when @debraspicher came across the same problem.

Thanks for looking in to the issue...I was struggling to source the cause or sequence of events.

NB: Wacom updated their drivers!..eek! (6.3.32.3)..updated signature...


APh & AD 1.7.1.445 + Beta AD 1.7.2.464 | APh 1.7.1.404 + Beta AP 1.7.2.464
APu 1.7.1.404 +Beta Apu 1.7.2.458

OS:Windows 10 Pro 1903 OS Build 18362.295
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 19.08.1(Adrenalin, 
Radeon Settings Version
19.1.1) + Wacom Intuous 4M with driver 6.3.35-3

 

 

Share this post


Link to post
Share on other sites

Took me a while to find this thread....and mentioned several times in forum..
initially found a way of getting around it by accessing Pen settings...but also noticed that updating to latest Driver update (6.3.34-3) seems to fix the issue. has not re-occurred since updating (hopefully gone...!:))
 

The problem is mentioned in the release notes:) 

'We fixed the problem where straight lines were being drawn preceding the start of a curved stroke when drawing quickly.' [2725]


APh & AD 1.7.1.445 + Beta AD 1.7.2.464 | APh 1.7.1.404 + Beta AP 1.7.2.464
APu 1.7.1.404 +Beta Apu 1.7.2.458

OS:Windows 10 Pro 1903 OS Build 18362.295
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 19.08.1(Adrenalin, 
Radeon Settings Version
19.1.1) + Wacom Intuous 4M with driver 6.3.35-3

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×