Jump to content
fii

Perspective filter render bug in Designer

Recommended Posts

Hi!

On iPad, I‘ve imported a document from Photo to Designer in order to have a live effect layer for the perspective filter. However, It renders not as expected: updates do not seem to happen until the canvas is moved and especially at higher zoom levels some parts are not rendered at all. To me, it seems like the renderer renders only a smaller area than it should.

Here is an example video with the live filter applied to a text layer: https://www.youtube.com/watch?v=YnmkbjunkA8

The issue exists for pixel layers, too, but seems less prominent.

 

I hope this will get fixed, because I don‘t see any other way to create the kind of text shadow effect as shown in the video.

 

Best regards, fii :)

Share this post


Link to post
Share on other sites

Hi Fii,

Welcome to the forums :)

If possible could you provide the file in question so I can look into this further for you :)

C

Share this post


Link to post
Share on other sites

Sure! Here is the file from the video, although it does not seem to depend on the specific file.

To see the problem, for example just try zooming into the shadow.

EDIT: I should also note that I did only observe the issue in Designer, while everything seems to work fine in Photo.

perspective.afdesign

Share this post


Link to post
Share on other sites

Interesting, I had some issues with the perspective filter in Photo on Windows the other day. Basically upon merging down the filter it introduced some artefacts... I am preparing a video on the issue and will post ist soon.

Share this post


Link to post
Share on other sites
9 hours ago, fii said:

Sure! Here is the file from the video, although it does not seem to depend on the specific file.

To see the problem, for example just try zooming into the shadow.

EDIT: I should also note that I did only observe the issue in Designer, while everything seems to work fine in Photo.

perspective.afdesign

Seems to work fine in IOS12.1 beta 5, don’t see any problems as you show in video. What IOS version are you on,? Do you have lots of apps open?


Affinity Photo 1.6.7 and Designer 1.6.1 on MAC Mojave 10.4 Beta, Affinity Photo 1.6.12.86 and Designer 1.6.4.45 on iPad Pro 9.7" IOS 12.3 beta, Affinity Photo 1.6.4 on Windows 10

 

 

Share this post


Link to post
Share on other sites

I'm running iOS 12.1 (at least I do now) on a 10.5" iPad Pro. I just tried closing all apps and rebooting my device, but problem still persists.

All I need to do to get the glitchy behaviour is to zoom far enough into the shadow.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×