Jump to content

Recommended Posts

Help! Whenever I import a manuscript PDF created from Pages into Affinity Designer, the page numbers all have a ">" symbol next to them and sometimes illustrations do too. I can usually delete these symbols, but for a 200 page document, this is a pain.

Share this post


Link to post
Share on other sites

Hi Rabboks,

Any chance you can upload the PDF file here to our internal Dropbox account and i can look into this further.

I did a quick test with a 2 page PDF with page numbers and didn't get any ">" Symbols next to them but the page numbers didn't display correctly, so that's a different issue i'll have to log. 

Share this post


Link to post
Share on other sites

I've uploaded a generic book template in both Affinity format imported from a PDF created in Pages and as a PDF exported from Affinity. On all the page numbers, there is a ">" symbol on top of the page numbers.  

Thanks for your help.

Share this post


Link to post
Share on other sites

Hi Rabboks,

Thanks for the files, could you upload the PDF you published from Pages, before it's been imported into Affinity.  This will allow me to log the actual PDF file that's being imported along with the .afdesign file as well.  I keep getting mixed results in my testing, sometimes it works fine and other times i get the >. 

I think it's how Affinity is reading the formula Pages will be using for the page numbers, but i could be wrong.

 

Share this post


Link to post
Share on other sites
On 10/25/2018 at 3:47 AM, stokerg said:

I keep getting mixed results in my testing, sometimes it works fine and other times i get the >. 

First, I have to say I rarely if ever use the Pages app & barely understand how to use most of its features, so I could be doing this all wrong.

That said, I created a very simple one page Page number test.pages document & exported it from Pages as Page number test.pdf. The page number was inserted 3 times, once as text in the body & twice in the footer, with each of them in a different font. Importing the PDF into Affinity Designer resulted in Pages number test.afdesign.

I did a few other tests with 2 page versions & with the different PDF import text options in Affinity Designer, but in all of them the results were the same: the added characters vary consistently by font, so for example Arial adds the > character, Helvetica Regular adds a colon, & so on.

Also, the Layers panel looks very odd, as shown below.
632350487_Layerspanel.jpg.864e94391f1492eaabf17cf329a2c807.jpg


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites

I've uploaded an un-exported version of the generic book template in a pages format. If I create a PDF from pages and open it in preview, it looks fine. The problem is the printer demands the PDFs be PDFX-1a:2001 or 2003 and that's what Affinity can do that Pages can't.

Share this post


Link to post
Share on other sites

@Rabboks, as a test have you tried changing the font used for inserted page numbers in your Pages document & seeing if that makes any difference in the PDF exported from Pages & imported into Affinity Designer?

In my simple test, the Arial font adds the extra > character to page numbers but other fonts add different characters.


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites
On 10/25/2018 at 10:47 AM, stokerg said:

I think it's how Affinity is reading the formula Pages will be using for the page numbers, but i could be wrong.

 

hi,

i don't think you're wrong. i have the same problem with the greater than signs in the page number fields when the imported .pdf file is generated by pages (and the page numbers are generated automatically). in my case i used the font georgia.
in publisher i removed the page number text fields by hand. i thought the solution would be to make a master page with only a page number field and to apply i to all my pages, but that doesn't work.

regards,
jan van de ven

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.