Jump to content
stwr

Mac 'spacebar' preview bug on import window.

Recommended Posts

Hi,

Software: Affinity Photo
Version: 1.6.11

I have discovered a bug while in the import window. It appears Affinity Photo does not give the spacebar functionality to the import window but rather 'hijacks/keeps' it as the "temporary move" hotkey.

This means when I preview a file to import using the spacebar functionality, it does indeed show a preview of the file, but straight after returns the functionality back to Affinity Photo, thus you are unable to close the preview window, or go to the next image with the arrow keys.

I've done a little screen capture to show you. Hopefully it makes sense.

https://youtu.be/io5fSPc043c

I have not yet tested the bug in Affinity Designer.

Cheers,

stwr

Share this post


Link to post
Share on other sites

Which OS are you on? I don't see this at all with Mac Sierra 10.12.6.

It could be a file size thing, I checked with smaller sized files with very few layers so the OS doesn't have to do too much lifting. Also do you have any  third party keyboard shortcut managers installed?


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.7.x.x

Share this post


Link to post
Share on other sites

Hi STWR,

Welcome to the forums :) 

I am unable to replicate this behaviour however I noticed you have a custom dock, do you have any other third party software installed?

Thanks

C

Share this post


Link to post
Share on other sites

Hi Guys,

I forgot to mention that I'm running macOS Mojave 10.14. That might be the issue?
I have just turned off uBar as Callum mentioned and can repeat the same issue. So that doesn't seem to be the problem.

Also I do not have any keyboard shortcut managers active fwiw.

Let me know what other digging I need to do.

Cheers,

stwr

Share this post


Link to post
Share on other sites

Here's the steps I take:

create a new document > drag in an image from finder (to avoid it being a pixel layer) > hit replace image in contextual menu > try and preview an image using spacebar (works) > trying to close the preview does not.

I just tried this on a separate fresh document and the bug persists.

https://youtu.be/xRsanmb52eM

stwr.

Share this post


Link to post
Share on other sites

Hi STWR,

I have now been able to reproduce this issue however it has been fixed in the Publisher beta so it should hopefully be fixed in the next Photo update.

Thanks

C

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.