Jump to content

Recommended Posts

Hi,

I'm working on Windows10 Pro and I simply cannot open any image file in Affinity Photo (current version, German). Nothing happens but the cooler gets louder sometimes. This happens since, I think, version 1.6x. All former versions worked well... very strange... any idea?

Thank you!!
Joerg

affinity_taskmanager.jpg

Share this post


Link to post
Share on other sites

Hi JoergB :)

Sorry to hear you're having trouble!

Is this happening when using File>Open, double clicking on the image in Explorer or dragging & dropping the image file into Affinity? (Or all 3 of these?)

Could you please confirm the file type you're trying to open? Do you see the following in the top right of Affinity Photo when attempting to open the image?
image.png

Apologies for all the questions, simply this isn't a common issue so I'd like to narrow down  as many variables as possible :) 

Share this post


Link to post
Share on other sites

Hi Dan C,

thanks very much for your help! To shortly answer your questions: All 3 of these cases and there is no info about loading...

When I try to close AffinityPhoto, a message appears, saying that one file is still in loading progress and closing the program is not possible until all files are fully loaded. Badly translated from German ;-)

Joerg

Share this post


Link to post
Share on other sites

Thanks for that info Joerg :)

What file type are you trying to open? Is this from a network folder or drive? If so, please double check you have the correct permissions set to edit files on the drive.

It may help to reset your Affinity Photo to default settings, you can reset your app back to its default settings by holding down the CTRL key while launching the app. When the Clear User Data window appears, click Select All and then Clear. 

Be aware that resetting your app back to its default settings will lose any custom settings such as keyboard shortcuts and brushes etc. To backup such settings before resetting the app, please watch our Affinity - Exporting User Settings and Keyboard Shortcuts video.

 

Share this post


Link to post
Share on other sites

Hi Dan,

sorry for the late feedback, I'm very busy at the moment...

I resetted the software and then tried to open a jpg file from my harddrive. Now there was a message in the upper right corner "loading 1 document" (translated). A few seconds later, the app crashed and I was asked to send the dump. So I did...

Then I tried to run it as administrator. Same... not even a message in the top right corner...

Then I uninstalled the software, cleaned registry, restarted the computer and reinstalled the software. Still not able to load any file...

Hope that helps...

Best,
Joerg

Share this post


Link to post
Share on other sites

That's no problem at all, thanks for taking the time to reply :)

I'm sorry to hear this didn't help. When re-installing the software, did you download a fresh copy of the .exe, or use the originally downloaded one?

Could you please try creating a blank document, saving this and then opening it from Windows Explorer (like you would an image file). Does this open correctly?

In the same document after testing the above, could you please try File>Place and select an image from the open dialog. Can you place this on the document as expected?

It may be that the exiftool.exe is not functioning correctly, and this is what's causing your images not to open. What file type are you trying to open? Is this from a network folder or drive?

Share this post


Link to post
Share on other sites

Hi Dan,

I can't even create a new file :/ Strange, that obviously nobody else does have this problem...

Your questions: I used the current version .exe file for setup. All files are on my harddrive. Filetypes are mainly JPG, PNG, TIFF (RGB and CMYK)

Thank you!!
Joerg

Share this post


Link to post
Share on other sites

Thanks for trying that, how very strange!

Can you confirm, are all of your graphics card drivers up to date? It may be that the document/image is loading, but the canvas is not being drawn correctly.

Under Edit>Preferences>Performance can you let me know what is set under Renderer?

Could you please try using the following uninstaller from Microsoft to uninstall Affinity Photo, then download a fresh version of the .exe from here and install this? I appreciate this has been done already but I'm concerned that the installer you already had downloaded may have been corrupted slightly.

https://support.microsoft.com/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

https://affinity.store/update/windows/photo/1/

 

Share this post


Link to post
Share on other sites

Hi Dan,

the renderer is "Intel(R) HD Graphics 3000". I uninstalled using the microsoft tool, then reinstalled a fresh copy in a new directory. Nothing changed...

Because noone else seems to have this problem, I think about picking up my computer, opening the window and...

Joerg

Share this post


Link to post
Share on other sites

Okay, no issue with the renderer. Are the drivers for your Intel HD Graphics 3000 fully updated?

I'd like to try something a little less orthodox, could you please try downloading the Affinity Designer trial from the link below and installing this. Can you open images/create new documents in Designer?

https://affinity.serif.com/designer/trial

Secondly, have you installed and programs recently that may affect your display or rendering? 

Share this post


Link to post
Share on other sites

Hi Dan,

you're right!! Same problem with current version of Affinity Designer (I have a registered version). Drivers are up to date. I often try new software demos, especially graphic tools and plugins, music software, VST plugins... What do you think, what kind of program could make the trouble? Something, that starts up with Windows10?

Thanks very much!
Joerg

Share this post


Link to post
Share on other sites

It sounds as though it may be an issue with the Windows user itself, be it a setting or a program installed but it may be difficult to discern which.

Could you please create a new Windows admin user then download and install the trial here, so that it's your only third party program installed. Can you open/create documents here? :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×