Jump to content
elgarak

Trouble inserting text 1.7.0.133

Recommended Posts

I do not know if this has been mentioned before (can't find it), if this is bug, or if I'm doing something wrong.

I thought the usual workflow (which worked for me before version 133) is: Make text box. Select text box. Choose "Insert Text from File", which should fill the selected text box (and below if the text is too long for the box).

The last few tests for me resulted in the text inserted to the right of the text box, with its own new text box somewhere way up top (outside the page). So I had to delete the text box I made, select the text box of the text, and move it how I wanted it, and re-adjust the text flow.

Seems like a bug, as I can't pre-set a couple of pages with boxes and a flow between them, and then fill them with text. 

Share this post


Link to post
Share on other sites

Interesting....

Just tried it again. New Affinity file, one page, one text box. Works as expected, text fills the text box. Undo insert text. Insert second page, make text box on 2nd page, make flow from first page and box to second page and box. Select first box, insert same RTF file as before. Text appears with its own text box way up high.

(I'm hesitant sending the RTF, as it is a text not written by me.)

Share this post


Link to post
Share on other sites

Hi elgarak,
Welcome to Affinity Forums :)
I'm having trouble reproducing this here (with build 133). Do you mind sharing your .afpub document and the rtf file for us to check out. I believe this may be some glitch due to the update which should be fixed by a reset. In any case I would like to test with your files. After uploading them using this link, press a hold ⌃(ctrl) while launching the app until a Clear User Data dialog appears. Keep the first three checkboxes ticked then press Clean. Are you able to reproduce the issue after the reset?

Note: all sent files will be deleted after checked and are only used for texting purposes.

Share this post


Link to post
Share on other sites

I have uploaded the files. Just to make sure: Affinity Publisher was running for some time. I just closed another file, made a new one, made a text box on the first and only page of the new file, and tried to insert the RTF. It showed up with its own text box and formatting/textwidth. That's when I saved the file.

Yesterday I had trouble re-creating the issue myself. It showed up with about fifty/fifty chance (feeled, I didn't count ;) ). I wasn't able to pinpoint which combination of actions caused it.

I am going to try a Clean start now.

Share this post


Link to post
Share on other sites

After a Clean start, it worked!

Seeing the Clean version, I just remembered that the context menu (right/ctrl-click) of the text box looked different when I had the trouble. The "Insert from File" command was NOT in it.

I'm trying to re-create the issue now...

Share this post


Link to post
Share on other sites

It did show up again after I made a master with page numbers, the expected four pages I need to get the text with text boxes and a flow between them. The file is attached, again saved just after I made the "Insert Text from File".

I had selected the first page/textbox. Its context menu did NOT show the "Insert Text from File" command (I select it from the Text menu). The context menu looked like it belonged to a drawing element.

RTF wrong insert 2.afpub

Share this post


Link to post
Share on other sites

Further test: I selected the text box with the Move Tool. The Move Tool was highlighted (as well as the text box). That's when the issue shows up.

If I highlight the Frame Text Tool before inserting text, everything works fine.

 

Double-checking...

Yup, that's it.

Share this post


Link to post
Share on other sites

And a further text: After a Clean start, the issue shows up, too. Reliably when the Move Tool is highlighted while the text box is selected.

Share this post


Link to post
Share on other sites

Hi, 

Thanks for the information, it does indeed seem that if the text caret isn't active it won't insert text into a selected text frame.

I've logged this for the developers to look at.

Thanks


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×