Jump to content
Saijin_Naib

Bug: Color/Gamut Clipping issue when RAW/RAF developing

Recommended Posts

It would appear that there is still the possibility that Affinity Photo can have issues with the color/gamut when developing certain RAW files. I know this was a big issue addressed in the v1.5 update as referenced here, but it would appear that there is still work that could be done to improve this behavior.

In all of the test photos, only Fuji RAW File Converter 3.x (SilkyPix 8.x engine) correctly rendered the color of the subject (ring) and didn't clip the colors. RawTherapee, DarkTable, LightZone, and CaptureOne v11 (Fuji) rendered it cool blue. All images are rendered with all processing off/neutral/default to ensure consistency.

For the Affinity Photo HDR and Median Stack images, I used a DCRAW script to dump both subframes from the RAF and composited them accordingly. As you can see, the development result is far superior to what the Serif RAW engine can produce.

Affinity Photo (RAW Develop):

ap2.thumb.png.92afd6edfffc7c48c9fdaeccf1b4c199.png

Affinity Photo (HDR Merge):

ap2_hdr.thumb.png.a63aad971c6412cef917778bd4d31f9f.png

Affinity Photo (Median Stack):

ap2_stack_median.thumb.png.2f15025204519a232b94cceeeb77e626.png

Share this post


Link to post
Share on other sites

Here are examples from other RAW processing engines to compare to. Not all fared well, and as noted above, only RFC rendered it correctly. DarkTable clipped a bit, visually similar to the RAW import on Affinity Photo. CaptureOne rendered the left side of the ring brighter, as it should have been, but the color was completely wrong.

SilkyPix nailed the color, brightness, everything. Except the processing defaults make the image look like mush due to the excessive smoothing.

LightZone:

lightzone2.thumb.jpg.d03a53df47d5c57f59ac5f290605ef1c.jpg

RawTherapee:

rt2.thumb.png.93eedc95176df5c068d1c5fd44a48169.png

 

DarkTable:

dt2.thumb.png.911ec34a221118d7b3f1057ab2f86760.png

CaptureOne v11 (Fuji Edition):

captureOne2.thumb.jpg.4995ce578ff19f96c86a87c896a9f0b0.jpg

RAW File Converter 3.x (SilkyPix 8.x):

silkypix2.thumb.jpg.23fa0b74cf5ca7ee7cd7546cce44d0d9.jpg

Share this post


Link to post
Share on other sites

Affinity Photo Beta for Windows 1.7.0.178 (RAW Develop)

image.thumb.png.a213b6e6e1f122e1a1ad51e4452b3ff4.png
All Assistant functions turned off, 32bit HDR as before. Shadow detail is recovered better, color is slightly more accurate and now the X-S1 Lens Profile is applied properly, but clipping is still a massive problem.

Share this post


Link to post
Share on other sites

Affinity Photo Beta for Windows 1.7.0.184 (RAW Develop)

image.thumb.png.d33a670d67449e7ce30c8908e0961d84.png

All Assistant functions turned off, 32bit HDR as before. Shadow detail is recovered better, color is slightly more accurate and now the X-S1 Lens Profile is applied properly, but clipping is still a massive problem.

The image appears to be unchanged from the Beta 178 rendering.

Share this post


Link to post
Share on other sites

image.thumb.png.e0be9f71a68f5189afacb68bea595681.png

All Assistant functions turned off, 32bit HDR as before. Shadow detail is recovered better, color is slightly more accurate and now the X-S1 Lens Profile is applied properly, but clipping is still a massive problem.

The image appears to be unchanged from the Beta 184 rendering.

Share this post


Link to post
Share on other sites

Perhaps you missed Gabe's comment above, but this is the wrong forum for discussions about the Beta. 

Perhaps a moderator will split this, but if not you should repost in the correct beta forum.


-- Walt

Windows 10 Home, version 1809, 16GB memory, Intel Core i7-6700K @ 4.00Gz
Affinity Photo 1.6.5.123 and 1.7.0.258 Beta
Affinity Designer 1.6..5.123 and 1.7.0.258 Beta
Affinity Publisher 1.7.0.270 Beta

Share this post


Link to post
Share on other sites
8 hours ago, walt.farrell said:

Perhaps you missed Gabe's comment above, but this is the wrong forum for discussions about the Beta. 

Perhaps a moderator will split this, but if not you should repost in the correct beta forum.

Perhaps you missed that this is an extant issue with the RAW engine that predates the beta and that I am keeping a consolidated log of changes in processing behavior in this single thread while referencing it in the appropriate Beta forum.

I hope it isn't split as the ability to easily compare rendering across the various engines and versions will become more difficult.

 

Share this post


Link to post
Share on other sites

Affinity Photo Beta for Windows 1.7.0.209 (RAW Develop)

image.thumb.png.d50e5510eb9a1b5f5b17f4d871df3a7f.png

All Assistant functions turned off, 32bit HDR as before. Shadow detail is recovered better, color is slightly more accurate and now the X-S1 Lens Profile is applied properly, but clipping is still a massive problem.

The clipping, however, does appear to be reduced compared to the v184 beta and v189? beta. I'm not sure what changes have occurred, but this appears to be headed the right direction.

Edited by Saijin_Naib
Forgot version string.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×