Jump to content
carina2cl

Affinity Photo and Designer loading .abr brush textures incorrectly

Recommended Posts

I encountered a problem with abr brush texture loading in both Photo and Designer. I've checked about this issue in the forums and only found two similar threads in the Ipad section of bug reporting and both are from November 2017. I just got both Photo and Designer this year, since among many other reasons (such as better vector workflow for Designer), one of them was their ability to import abr brushes. I love collecting brush and I regularly used many affinity brushes, like @paolo.limoncelli's brushes as well as frankentoon's brushes. They are all great brushes and I have fun using them. It's just that sometimes I just want to use various different brushes to experiment with them. 

What I found out when searching about this issue was that some abr files is made using newer versions of Photoshop, and they might require adjusting in order to be read properly in Photo and Designer. I think it had been 2 updates since the this issue was brought up in the two threads I mentioned and this issue still persists.  I tried importing the same brushes in Artstudio Pro on the Ios and it the app seemed to import them properly. 

Right, now into the details of this bug. Whenever I import abr brushes in Photo or Designer, the texture image of the brush will load incorrectly. What happens is that, instead of a single picture of a seamless texture, the image shown will be smaller tiles of the texture. I'll attach some pictures below. I think some brushes even have only three small tiled image at the top with black  or white fill and sometimes other tiled texture below it. It only happens to newer abr files from Photoshop cc as those from Photoshop cs suite works fine. I realise it may take a while to implement fix for newer abr files, but I feel the need to bump this issue to let it be known. I would like to thank you the developers for such wonderful apps and I hope that this issue can be resolved soon.

Regards

Carina

Images:

The first picture showed brush that has some proper texture loading

image.thumb.png.93f4a071bf7ac7dc8b07c03dbd36974f.png

this second was the one with the tiled texture image

image.thumb.png.230493772001d93ea8560c715d2e2fbc.png

The last picture was three tiled texture image at the top with different textures at the bottom, some brushes it can have a black or white fill at the bottom instead.

image.thumb.png.fdfd04bd04061ba85ab8150fe3269f7f.png

 

 

 

 

 

Share this post


Link to post
Share on other sites

Hi Carina,

thank you for the mention!

Just to let you know: Advanced PS brushes (in partticular KTW and mine, or many others out there) will never behave as in PS because of some differences in engines.

I'm pretty sure the texture thing will be solved by devs, but all brushes are going to be normalised to Affinity's engine.

 


The white dog, making tools for artists, illustrators and doodlers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.