Jump to content
JohnRH

Accurate black versus rich black in pdf export

Recommended Posts

I created a document and placed some text. Text was selected and specified as (0%C, 0%M, 0%Y, 100%K)

Upon opening pdf in Acrobat (Pro) black appears as rich black (72%C, 66%M, 66%Y, 78%K) not true black (100%K).

Any thoughts? my error or Publisher glitch?

Share this post


Link to post
Share on other sites

Hi Wim,

Yes the file was CMYK/8.
I've been putzing around and have come up with:
File colour profile was Coated GraCol 2006 (ISO 12647-2-2004) and if I change the profile to match that in Acrobat Pro then I get my real 100% black with CMY reading 0% as it should. If I spec the file as US Sheetfed Coated v2 then in Acrobat with the same profile I get 72%C, 66%M, 66%Y, 78%K. I spent a couple of decades in Prepress in a large, up-to-date Printshop and we used the Gracol profile which worked best with our computerized platesetter. Not sure why this is happening, hopefully the developer guys will come up with a solution. Seems like a colour profile issue. Maybe we need an "accurate black" choice in Publisher preferences similar to InDesign.

trial (Coated GraCol).pdf

trial (US Sheetfed).pdf

Share this post


Link to post
Share on other sites

HI JohnRH

If you set the document to be one profile then look at it using a different profile in the viewer it is going to be different values. You can even simulate this in app using a soft proof adjustment and the colour picker. You get the same effect in exports using the accurate black option in ID if you view that in acrobat using a different profile to the one set in the document


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

100% Black only drop shadows convert to 4/C when exporting to PDF.

I can confirm that by looking at the separations in Adobe Acrobat. 100% Black specified in Affinity becomes a 4/C Black in the PDF. This should have nothing to do with profiles or soft proofing. Pitstop also shows the same problem.

The same problem happens with Black only text - it converts to 4/C text when exported as a PDF.

Please open, check settings, and convert the attached file to a PDF. Then open the resulting PDF in a viewer like Acrobat and see for yourself that 100% K has been converted to 4/C Black.

 

PDF test.afpub

Share this post


Link to post
Share on other sites
10 minutes ago, gordo said:

100% Black only drop shadows convert to 4/C when exporting to PDF.

I can confirm that by looking at the separations in Adobe Acrobat. 100% Black specified in Affinity becomes a 4/C Black in the PDF. This should have nothing to do with profiles or soft proofing. Pitstop also shows the same problem.

Please open, check settings, and convert the attached file to a PDF. Then open the resulting PDF in a viewer like Acrobat and see for yourself that 100% K has been converted to 4/C Black.

 

PDF test.afpub

Open the placed image (double-click on it). Copy it. Close and delete the placed version. Paste the copied version. Add your drop shadow again and make sure the drop shadow is using 100% K.

Should be fine now.

Share this post


Link to post
Share on other sites
7 minutes ago, MikeW said:

Open the placed image (double-click on it). Copy it. Close and delete the placed version. Paste the copied version. Add your drop shadow again and make sure the drop shadow is using 100% K.

Should be fine now.

The result is the same. 100% K becomes 4/C K (shadow and text).

This is a showstopper.

Can you post an Affinity file that you've converted to PDF where 100% K stays 100% K?

 

Share this post


Link to post
Share on other sites

Here's the resultant PDF.

But the way Serif's software has worked for years is 100%, if using the as-shipped swatches, is they really are not (unless you remake them as I have). So edit the color of the shadow. It likely says it is 100%K. Move the K slider down a ways and then back to 100%. See if that works.

The PDF is attached...

PDF test.pdf

Share this post


Link to post
Share on other sites

Tried moving the slider and using the swatch instead same result 100% K becomes 4/C. :-(

I don't know what you're doing that I'm not. Or what settings worked for you.

 

Share this post


Link to post
Share on other sites

I opened your file. And made a PDF. Same problem - 100K became 4/C.

So it seems to be a setting somewhere for PDF creation?

Is there somewhere a setting that would cause this?

Share this post


Link to post
Share on other sites

Unless there is one of three things happening, I wouldn't know what to suggest. Not in any particular order. 

One, it is possible that Affinity applications point to the swatch name and there's a difference between our swatches. If this is the case, edit the Black swatch. Make sure you edit using the CMYK sliders. Move everything down to zero, then the K slider back to 100%. Recheck the shadow and pick that edited swatch.

Two, make sure the document color space is CMYK/8. Make note of the color profile used. When you create the pdf click the More button and select the same profile in the appropriate place.

Three, I forgot by now what I was thinking.

So try the two things.

Share this post


Link to post
Share on other sites

Nope.

I started all over with a new document.

Still doesn't work :-(

100K becomes 4/C

Must be the third thing.

Attached are screen shots of my settings.

4.png

2.png

1.png

3.png

Share this post


Link to post
Share on other sites

Out of curiosity, what color profile are you using? And is it being reported in Acrobat/PitStop as the proper one?

It may be a Mac (you) versus PC (me) thing I guess. Since the Windows AD version came out I have shouted about the swatches needing revamped. I don't think they work well...and this is one issue I ran into with the very first Windows beta of AD. But the above (swatch editing) is what rectified it for myself.

Hopefully the developers have been reading along. Because especially in a layout application, it should be difficult to have this happen. Heck, lots of things ought to be made dead simple.

Share this post


Link to post
Share on other sites

US Sheetfed Coated V2 - but that shouldn't matter.

My version of Acrobat Pro doesn't appear to actually say what the embedded profile is - but that shouldn't matter with a CMYK file.

This issue of 100K being converted to 4/C has been reported by some printshops to me so I'm not the only one with this problem.. It's a real showstopper for them (and me).

I don't know why you were able to create a proper PDF - maybe the Win version is not quite the same as the MAC version?

Share this post


Link to post
Share on other sites

The PDF I uploaded does display the output intent profile in Acrobat's Output Preview. If you switch the output intent in Acrobat's Output Preview, would I be correct that the shadow is then correct? If so, then for whatever reason, it is not being embedded/referenced properly and so could be the issue.

If that doesn't make it correct...then I have no idea other than to punt to the OS difference thing.

Share this post


Link to post
Share on other sites

Here is an observation that might be mildly interesting:

  • Create a new document and a layer
  • Add an outer shadow using Layer Effects > Outer Shadow, and set the colour chooser to RGB
  • Then close the document
  • Now open “PDF test.afpub” you uploaded in this post
  • Open the layer effects dialogue, and you will find that the shadow colour is now defined in RGB
  • When you switch to CMYK, you will see composite black instead of true black

I don’t know if that will distort the PDF output. But I would imagine, if someone creates a layer effect with in CMYK, this information should be preserved when his document is opened on a different system. Hmm. ;)

 

Share this post


Link to post
Share on other sites
15 minutes ago, MikeW said:

The PDF I uploaded does display the output intent profile in Acrobat's Output Preview. If you switch the output intent in Acrobat's Output Preview, would I be correct that the shadow is then correct? If so, then for whatever reason, it is not being embedded/referenced properly and so could be the issue.

If that doesn't make it correct...then I have no idea other than to punt to the OS difference thing.

Boom!

 Changing the output simulation profile in Acrobat makes the shadow correct!

So that seems to be the problem.

Unfortunately that means that prepress would need to intervene and fix it.

Share this post


Link to post
Share on other sites
17 minutes ago, gordo said:

Boom!

 Changing the output simulation profile in Acrobat makes the shadow correct!

So that seems to be the problem.

Unfortunately that means that prepress would need to intervene and fix it.

As you have Acrobat, you can make a profile embedded. That may be a temporary good fix--assuming Mac APub is broken.

Share this post


Link to post
Share on other sites
37 minutes ago, MikeW said:

As you have Acrobat, you can make a profile embedded. That may be a temporary good fix--assuming Mac APub is broken.

Yes, embedding the profile in Acrobat and resaving it works. That also fixes the type converting from 100K to 4/C problem. So, a workaround to a bug. LOL

Thanks for your patience. I hope the developers have made note of it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×