Jump to content
Clavote

[Fixed] "drag to resize" changes stroke width when printed

Recommended Posts

Complicated situation ahead (sorry English is not my main language)

  1. with the pen draw a horizontal line across the page (stroke width 5pt)
  2. duplicate the line 4 times below
  3. with the move tool shorten some of the duplicated lines to different sizes with a simple drag (drag to resize selection)
  4. although the stroke width wasn't changed, when I print, I get 5 lines with different stroke width
  5. when I print to PDF with Pdf-XChange the strokes display and print as intended (same stroke with)


redo points 1-2

now

with the move tool shorten some of the duplicated lines to different sizes with shift+Drag (preserve aspect ratio)

the print is right (same original stroke width)

there is something wrong!!

in case 1
the print driver follows the "preserve aspect ratio" scheme by increasing or decreasing the stroke width

in case 2
neither the display nor the print changes when resizing by shift+Drag (preserve aspect ratio)
the stroke with is not affected by the operation (wich I can understand btw.)

to me the conclusion is: do not print from AD or AP as any thick stroke could be looking different than intended

hope somebody can reproduce this

printed on a Hp laserjet 3015 PCL5

 

 


Windows 10 pro 64; HP elitebook 8540; A-Designer latest; A-Publisher Beta; A-Designer Beta

Share this post


Link to post
Share on other sites

Hi Clavote,
Welcome to Affinity Forums :)
Check if you have Scale with object ticked or not in the Stroke panel. This affects the results you get. If it is ticked the stroke's width will be reduced when you shrink the line because it's being scaled along with the length of the line, otherwise it will kept the stroke's width.

Share this post


Link to post
Share on other sites

Thanks Meb

Half of my problem is solved
the printing part is still strange


Windows 10 pro 64; HP elitebook 8540; A-Designer latest; A-Publisher Beta; A-Designer Beta

Share this post


Link to post
Share on other sites

Thanks for your help with this bug. We have now resolved the problem and will make the fix available in the next Windows release.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×