Jump to content
ckujawa

CTRL + Click issue

Recommended Posts

Hi! I'm running Win 10 with the latest beta of publisher. I'm trying to create a new master page and attempted to copy a block of text as I would in Designer using CTRL + Left click. In Designer, I can lift off of CTRL before releasing the mouse button and the copied text follows the cursor (and is placed when I release the mouse button). In Publisher, when I let up on CTRL, I am suddenly *moving* the original text.

Share this post


Link to post
Share on other sites
2 hours ago, A_B_C said:

(This report should probably be moved to the Windows section.) :)

I have noticed quite a few posts about Windows bugs here, in the 'on Mac' bug report section. I am not sure why. Is it maybe because the Mac one is listed before the Windows one in the 'parent' Affinity Publisher Beta Forums section?


Affinity Photo 1.8.3, Affinity Designer 1.8.3, Affinity Publisher 1.8.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 
1.8.3.180 & Affinity Designer 1.8.3.2 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.3.1

Share this post


Link to post
Share on other sites

@ckujawa   Although ctrl+drag works in ADesigner and not in APublisher, alt+drag works in both


-------------------------------------------------------------------------------------------------------------------------------
Win10(2004)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites
59 minutes ago, haakoo said:

@ckujawa   Although ctrl+drag works in ADesigner and not in APublisher, alt+drag works in both

Alt-drag overrides snapping, so we need to be able to use Ctrl-drag instead. And both methods should work consistently across all apps in the Affinity suite.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites
1 hour ago, αℓƒяє∂ said:

Alt-drag overrides snapping, so we need to be able to use Ctrl-drag instead. And both methods should work consistently across all apps in the Affinity suite.

Only if you keep alt pressed while dragging,select item by alt+click, release the alt button but hold the mouse to drag ,makes snapping possible again.
But yes,  both should work consistently in all apps.

 


-------------------------------------------------------------------------------------------------------------------------------
Win10(2004)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

This looks like it might be a general 1.7 change so I image it will be the same when designer rolls around.  pressing ctrl again after you let go will go back to copying the object rather than moving it. Tbh I'm not sure if this is an intentional change or an oversight of a tool rework yet


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Having tested this on both Designer/Mac and v58 of Publisher/Mac, I must say Publisher does it absolutely right (although I think not all of the time - maybe a bug...)

The modifier key should not have to be pressed when you start dragging. So while "normal-dragging" I can decide which key I want to add to achieve my goal!

Example (Pub1.7mac):

  • click on rectangle,
  • drag-start to approximate destination, hold mousebutton down,
  • press and hold shift and than command-key.
  • release mousebutton
  • -> made 45degree copy aligned on other object.

Designer 1.6 does not recognize if I press command to make a duplicate AFTER starting to drag, which is bad.

 

edit: but I'm sorry if I confuse @ckujawa (on windows) with my Mac Command-Key, as this was obviously a Win-thread, wrongly posted in Mac. Yet the new behaviour should still be consistent across systems.


  • Production-System: iMac (21,5-inch, Late 2013), 16GB RAM, 2TB nvme-SSD, running on 10.14.6 Mojave;
  • Display Setup: 27" Thunderbolt Display primary + 21,5" iMac-Display secondary for palettes;
  • Keyboard-Layout: German apple extended keyboard (aluminium);

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.