Jump to content
Natalie V

Spellcheck?

Recommended Posts

Hello!

I've been trying to right click on a word highlighted by spellcheck, but can't get a dialogue box to add the word to the dictionary or select an alternate spelling.

Let me know if there's an alternate way I should be using this. Thanks!

Share this post


Link to post
Share on other sites

Also working fine for me (beta 1.0.7.58, High Sierra, & US English text).


Affinity Photo 1.7.1, Affinity Designer 1.7.1, Affinity Publisher 1.7.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.1.143 & Affinity Designer 1.7.1.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.3.1

Share this post


Link to post
Share on other sites
21 minutes ago, Chris B said:

I'm struggling to reproduce this on build 1.7.0.133.

Has build 133 been released?


Affinity Photo 1.7.1, Affinity Designer 1.7.1, Affinity Publisher 1.7.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.1.143 & Affinity Designer 1.7.1.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.3.1

Share this post


Link to post
Share on other sites
1 minute ago, R C-R said:

Has build 133 been released?

Not to us :)


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

Hi Natalie V,
Welcome to Affinity Forums :)
Do you have the caret (cursor) inside the text frame of just the text frame selected (no caret inside)? What tool do you have selected when you right-click the text?

It will not work with the Move Tool selected unless you double-click the word first changing it to one of the text tools depending on the type of the frame. If you right-click with one of the text tools selected it should display the correct contextual menu with the options you are looking for.

Share this post


Link to post
Share on other sites

I think there is some confusion about the Spelling feature in Publisher. At least I was confused at first. When using 'Check Spelling' Publisher will look for the next word with an error and highlight it. Indeed it is strange that there are no options there to do anything other than correcting the mistake. If it is not a mistake, you have no option to add it to a dictionary.

People who expect this behaviour should use the 'Spelling Options' feature. That's the dialog most editors will want to use to spellcheck their story. Here you do have options to ignore or learn mistakes. This option has a shortcut key, because it is the most likely tool to do spellchecking.

Using better labels could solve the confusion I guess, something like this:

Spelling Options => Spellcheck (or Check spelling with options)

Check Spelling => Find next spelling error

Share this post


Link to post
Share on other sites

I think you left out the third possibility, Wim.

If you have Publisher checking spelling as you type, then it will provide a red underline on a misspelled word to highlight it. If you right-click on such a word, and Publisher has suggestions for as different spelling, you can choose one, or tell Publisher to ignore the misspelling, or to learn the word and add to the dictionary.


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

Hi I'm using release 257 in windows - when I right click on an underlined word nothing happens. No suggestions, no dialogue - what am I doing wrong please. Is there something which needs to be set up?

Thanks

Michael

Share this post


Link to post
Share on other sites
4 minutes ago, micornelius said:

I'm using release 257 in windows - when I right click on an underlined word nothing happens. No suggestions, no dialogue - what am I doing wrong please. Is there something which needs to be set up?

What is your UI language, and what spell-checking language do you have specified for that text?

Can you provide a screenshot?


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

Hi Have English United Kingdom in all three locations, screen shots below. I notice that on the UI screen there was an asterisk requesting a restart to apply. I have 1) restarted Publisher no change, 2) changed to English US and then back again with restarts following each and a complete reboot of my pc. On doing letter discovered windows lurking is background with an update thus delay in getting back to you.

It seems the restart asterisk doesn't go away after a restart.

Thanks

Michael

2019-03-13 (3).jpg

2019-03-13 (1).jpg

2019-03-13 (2).jpg

Share this post


Link to post
Share on other sites
7 minutes ago, micornelius said:

It seems the restart asterisk doesn't go away after a restart.

The “restart asterisk” is a footnote indicator linked to the asterisk against the label for the ‘Language’ dropdown list, to tell you that a change of UI language requires a restart.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Alfred thanks but as I said I already tried that. It doesn't go away and the spell checker doesn't open a dialogue to suggest correct spelling/learn etc

Share this post


Link to post
Share on other sites
4 minutes ago, micornelius said:

It doesn't go away

What I was trying to say is that we shouldn’t expect it to go away, since it’s always the case that a change of UI language requires a restart.

Perhaps it would help if you were to supply the information that Walt asked for:

 


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites
On 3/13/2019 at 1:54 PM, micornelius said:

But I did above 25 mins ago. I uploaded three images showing the language setup as requested by Walt.

You showed us the settings for the paragraph style named Para, but you did not show us anything that demonstrates that that style is applied to your text. The only screenshot that showed your text (with red underlines) with the Context toolbar visible seems to show that there is no paragraph style applied.

Can you provide a sample .afpub file that has the problem?


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

Hi Walt,

Many thanks for coming back to me. I manged to resolve the matter. The Word file I was copying and pasting from was set up with both English and USA dictionaries - with USA as the primary. Thus it seems it was conflicting with Publisher UK. So I stripped the USA dictionary from Word and everything started working after I cut ans pasted to a fresh Publisher file.

Again thanks for your assistance.

Regards

Michael

Share this post


Link to post
Share on other sites

How is spelling supposed to work?

Usually in programs, it's underlined in red but nothing ever happens in Publisher?

 

 

2019-06-28 16_53_06-Affinity Publisher.jpg

Share this post


Link to post
Share on other sites
3 hours ago, km.au said:

How is spelling supposed to work?

Usually in programs, it's underlined in red but nothing ever happens in Publisher?

You specify the spelling language in the Language field of the Character panel (or in the corresponding fields in the Character or Paragraph Text Style you've applied to the text. What language have you specified, or what language has it defaulted to?

And what language have you specified for the UI in Preferences, General?


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×