Jump to content

Recommended Posts

Given that Fuji have released the "X-T3" with >26mP is this the time Serif to finally get their RAF handling up to the speed of the Nikon,Canon RAW files??


MacPro (late 2013), 24Gb Ram, D300GPU, Eizo 24",1TB Samsung 850 Archive, 2x2Tb Time Machine,X-t2 plus 50-140mm & 18-55mm. AP, FRV & RawFile Converter (Silkypix).

Share this post


Link to post
Share on other sites

Hee Hee. Must be only Fuji user ;-)


MacPro (late 2013), 24Gb Ram, D300GPU, Eizo 24",1TB Samsung 850 Archive, 2x2Tb Time Machine,X-t2 plus 50-140mm & 18-55mm. AP, FRV & RawFile Converter (Silkypix).

Share this post


Link to post
Share on other sites

Look here


Affinity Photo 1.7.3.481 :   Affinity Photo-Beta 1.8.0.486   :    Affinity Designer 1.7.3.481:  Affinity Designer-Beta 1.8.0.486:

Affinity Publisher-Beta 1.8.0.502:   Affinity Publisher 1.7.3.481:    Windows 10 Pro  (Version  1909 Build 18363.476)

 

Share this post


Link to post
Share on other sites

Good to see this, BUT, it is not the opening that I was really concerned with. The time taken is the point. Affinity would and still does open my old Nikon & Canon Raw files in a quarter of the time it takes to open a Raf of similar proportions (Mp).

Since moving to Fuji the time to edit my images has doubled. That was my point. Not the capability but the lack of rapidity ;-)


MacPro (late 2013), 24Gb Ram, D300GPU, Eizo 24",1TB Samsung 850 Archive, 2x2Tb Time Machine,X-t2 plus 50-140mm & 18-55mm. AP, FRV & RawFile Converter (Silkypix).

Share this post


Link to post
Share on other sites

Maybe be the loading times better in the version 1.7 for Fuji.
The Hope dies last.


Affinity Photo 1.7.3.481 :   Affinity Photo-Beta 1.8.0.486   :    Affinity Designer 1.7.3.481:  Affinity Designer-Beta 1.8.0.486:

Affinity Publisher-Beta 1.8.0.502:   Affinity Publisher 1.7.3.481:    Windows 10 Pro  (Version  1909 Build 18363.476)

 

Share this post


Link to post
Share on other sites

Actually losing quite a bit of confidence in AP. Time taken for adjustments, text tool crashes, pixelation, just three to start with. Hmmmmm. Bit of a grumbler at the moment :-(

I don't think I would be at all happy if my job depended on AP at the moment. Ram using AP, Pixelmator, and sundry others as each one fails in some way or another to be stable.


MacPro (late 2013), 24Gb Ram, D300GPU, Eizo 24",1TB Samsung 850 Archive, 2x2Tb Time Machine,X-t2 plus 50-140mm & 18-55mm. AP, FRV & RawFile Converter (Silkypix).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.