Jump to content
Gilescooperuk

Font line spacing problem

Recommended Posts

Well maybe not a problem but an odd behaviour.

Below are two documents on the left Affinity Publisher, on the right Swift Publisher.

Both are using for the body text Helvetica 9pt standard text, and the pages are both set the same.

The text spacing between letters is the same, however I cannot see how to get the spaces between lines down in AP to the same level as SP. 

Both programs should (I think) be able to look the same with the same font but I am puzzled here.

ap problem.jpeg

Share this post


Link to post
Share on other sites
11 hours ago, Gilescooperuk said:

Well maybe not a problem but an odd behaviour.

Below are two documents on the left Affinity Publisher, on the right Swift Publisher.

Both are using for the body text Helvetica 9pt standard text, and the pages are both set the same.

The text spacing between letters is the same, however I cannot see how to get the spaces between lines down in AP to the same level as SP. 

Both programs should (I think) be able to look the same with the same font but I am puzzled here.

 

Have you just copied and pasted the text out of your old newsletter into Affinity Publisher? I found the same issue copying text in from an InDesign newsletter. If you highlight the text and go to the Paragraph panel, then there is a leading or line-spacing section. I found that it was set to "(13pt)", and on clicking it saw that it was set to "At least" "13pt". I changed it to "Exactly" "13pt" and then my lines were spaced as I wanted them.

Does that answer your question? (I'm writing this from memory without Publisher in front of me, so the exact words might be very slightly different, but hopefully enough for you to get the gist.)

Share this post


Link to post
Share on other sites

Hi @Gilescooperuk I think what you want to experiment with is the "paragraph leading".  My screenshot below shows the same text with two different leadings applied…

leading.png


—— Gary ——
macOS: 10.13.6
iOS: current release
Photo/Designer/Publisher: current releases

Share this post


Link to post
Share on other sites

OK I think this one might be a bug - to do with the small font size I am using

The document is A5 format using 9pt text for the font. Have a look at the screenshots - anything smaller than 11 point doesn't respect the line spacings but larger seems to work fine.

I have attached the afpub document as well...

Curious....

 

Giles

 

5 point.jpeg

7 point.jpeg

9 point.jpeg

11 point.jpeg

14 point.jpeg

eatoc new test.afpub

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×