Jump to content
PatrickOfLondon

How can you elect to see paragraph marks, newlines, and similar non-printing characters?

Recommended Posts

Please excuse my question if I've failed to see something that's evident, but I cannot find in Affinity Publisher Beta a way of toggling on and off the viewing of non-printing characters, such as paragraph marks, newline characters, spaces, tab characters, and so on, within text-frame text.

If someone could please show me how to make these characters visible, I'd much appreciate it. Thanks in anticipation.

Share this post


Link to post
Share on other sites

Found it: Text menu > Show Special Characters

Searching in Help for 'special characters', then clicking on the six question marks ??????, and scrolling down to the bottom of the resulting help article, will reveal this information.

Thanks Seneca, just saw your reply after posting mine.

Edited by PatrickOfLondon
After seeing Seneca's reply

Share this post


Link to post
Share on other sites

Hi Ken Emeigh,
Welcome to Affinity Forums :)
What version are you using (Affinity Publisher Beta ▸ About...)? The latest version is 1.7.0.57

[EDIT] This is indeed a known bug as carl123 pointed out. Restarting the app as suggested should fix the issue. If not press and hold ⌃(ctrl) while launching the app then select Clear from the dialog that will open.

Share this post


Link to post
Share on other sites

@Ken Emeigh

That menu is from Affinity Photo ,which is a reported bug, try restarting Publisher again.


Due to the ongoing Brexit negotiations, punctuation, spelling and grammar will be used sparingly until further notice.

Share this post


Link to post
Share on other sites

The attached image is just to illustrate the differences between the menu Ken Emeigh had and the menu I have.

Hopefully if Ken carries out the steps carl123 and MEB have provided, Ken's menu will be the same as the Windows one.

Affinity Publisher Beta Text Menu differences.jpg

Share this post


Link to post
Share on other sites

I tried to use the search icon to find special characters as I read in another post somewhere. I was able to enter them into the find, and by copying and pasting, also in the replace box, however the boxes for replace and replace all  remained greyed out.

Share this post


Link to post
Share on other sites
4 minutes ago, jrkay said:

I tried to use the search icon to find special characters as I read in another post somewhere. I was able to enter them into the find, and by copying and pasting, also in the replace box, however the boxes for replace and replace all  remained greyed out.

The buttons for Replace and Replace All are not active until you have actually found something and the search results are showing. Do they remain greyed out when you press Find and actually locate the text from the Find box?


-- Walt

Windows 10 Home, April 2018 Update (1803), 16GB memory, Intel Core i7-6700K @ 4.00Gz
Affinity Photo 1.6.5.123 and 1.7.0.209 Beta
Affinity Designer 1.6..5.123 and 1.7.0.209 Beta
Affinity Publisher 1.7.0.221 Beta

Share this post


Link to post
Share on other sites

Strange. Report it as a bug, in the appropriate OS bug forum?


-- Walt

Windows 10 Home, April 2018 Update (1803), 16GB memory, Intel Core i7-6700K @ 4.00Gz
Affinity Photo 1.6.5.123 and 1.7.0.209 Beta
Affinity Designer 1.6..5.123 and 1.7.0.209 Beta
Affinity Publisher 1.7.0.221 Beta

Share this post


Link to post
Share on other sites
7 minutes ago, jrkay said:

Correction, they do stay greyed out when I press find.

When you press find are the character actually found and highlighted in the text?


Due to the ongoing Brexit negotiations, punctuation, spelling and grammar will be used sparingly until further notice.

Share this post


Link to post
Share on other sites

Then that's why Replace and Replace All are greyed out. You must have a results list before they will work.

 


-- Walt

Windows 10 Home, April 2018 Update (1803), 16GB memory, Intel Core i7-6700K @ 4.00Gz
Affinity Photo 1.6.5.123 and 1.7.0.209 Beta
Affinity Designer 1.6..5.123 and 1.7.0.209 Beta
Affinity Publisher 1.7.0.221 Beta

Share this post


Link to post
Share on other sites

Hello! I am totally new here! I'm glad Patricko'London posted this question, it's exactly what I came here to find. I couldn't find it in my previous beta, but I'm used to calling them invisibles, so I might have just missed it. After reading the question I opened my brand new beta version and it was there. Just out of curiosity I'm going to load my previous beta to see what's there.  Thanks. I'll go to the intro forums next, but I was glad to find this and had to post. Thx again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×