Jump to content
Sign in to follow this  
GarryP

Place Image tool inserts selected image into currently selected Picture Frame

Recommended Posts

I don't know whether this is expected behaviour but I was just wondering what other people thought about it.

In Designer, you can have this work-flow:
1. Select Place Image tool;
2. Choose image and OK dialog;
3. Click or drag where you want the image to be;
...with the Image Layer that's just been created selected...
4. Select Place Image tool;
5. Choose image and OK dialog;
6. Click or drag where you want the image to be;
7. Image will be put in a separate layer as expected.

In Publisher this behaviour is replicated, however, using a slightly different work-flow gives a different result:
1. Select Picture Frame tool;
2. Choose image and OK dialog;
3. Click or drag where you want the image to be;
...with the Picture Frame Layer that's just been created selected...
4. Select the Place Image tool;
5. Choose image and OK dialog;
6. The image in the Picture Frame is now replaced.

NOTE: As an additional issue, even if you don't have the Picture Frame selected, the image in the last-created Picture Frame will flash very briefly to show the newly selected image before reverting back to the previous image and allowing you to click/drag the position of the new image.

Personally I think this could be 'wrong' behaviour. When I use the Place Image tool I would expect to be able to create a new image layer at all times. The Replace Image button on the context bar is there if I want to replace the image in the currently selected Picture Frame - even if one doesn't yet exist - and the Place Image tool should work the same way - creating a new image layer - no matter what is currently selected in both Designer and Publisher (except in the instance below).

I have also noticed that, if you have multiple Picture Frames, with no selected Picture Frame, when you use the Place Image tool you can mouse over the Picture Frames and see a preview of the image in each frame you mouse over. This seems like very nice behaviour which I would like to keep but I don't really like the idea of the image being immediately replaced when a Picture Frame is already selected.

What do other people think?

Share this post


Link to post
Share on other sites

It seems logical to me that the Place Image Tool should place the image in the currently selected picture frame. If that’s not the result you want, it’s easy enough to deselect the picture frame beforehand.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

I totally agree that it's easy enough to deselect the Picture Frame before using the Place Image tool, and I can learn to do this if necessary.
What I'm wondering is whether it's something I should have to do. As it is, the Place Image tool works differently depending on what's selected:
* Image Layer selected - you create a new Image Layer;
* Picture Frame selected - the existing image is replaced.
This means that the user needs to remember that the same tool works differently in each situation and it could be a bit confusing. I thought it was a bug at first because I was used to the way Designer worked but, since Designer doesn't have Picture Frames, I didn't know if this was really a bug or just a different - and possibly better - way of working.

It's not a major problem and I can get used to it, I just thought it might be worth discussing before the behaviour is 'set in stone'. I've used software in the past where you have to get used to using a feature in a certain slightly weird way because "that's just how it's been since the start and we're not going to change that now as it will get on the nerves of existing users". Since there are no users of the 'real' software yet, it might be good to check that it's doing things in the best and most intuitive way it can. Doesn't do any harm just to consider it for a while at this stage of development.

Share this post


Link to post
Share on other sites
3 minutes ago, GarryP said:

This means that the user needs to remember that the same tool works differently in each situation and it could be a bit confusing. I thought it was a bug at first because I was used to the way Designer worked but, since Designer doesn't have Picture Frames, I didn't know if this was really a bug or just a different - and possibly better - way of working.

I do see where you’re coming from, Garry, and I agree that it’s worth discussing at this early stage. :)


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.