Jump to content

Recommended Posts

I've been having trouble indenting number lists. However, with perseverance I found a 'text ruler' that does the job perfectly. Just putting this post up to help anyone else who's wondering how to adjust margins, without playing around with the text box. File attached. Don't forget to update the style.

Great feature thank you Serif!

Number List and Indent.afpub


iMac: iMac (Retina 4K, 21.5-inch, 2017)  -   3.4 GHz Intel Core i5   -   8 GB 2400 MHz DDR4  -  Radeon Pro 560 4096 MB 

Windows: Nvidia gtx 960m 4k uhd 2gb ram video (Windows 10 Pro) -  Laptop screen (resolution 3840x2160 magnified 300%)

Share this post


Link to post
Share on other sites

Indenting paragraphs can be done with the Spacing section of the Paragraph panel. We didn't duplicate those options in the Bullets and Numbering section, to save some screen space as we hoped it wouldn't be necessary.

Share this post


Link to post
Share on other sites
43 minutes ago, Dave Harris said:

Indenting paragraphs can be done with the Spacing section of the Paragraph panel. We didn't duplicate those options in the Bullets and Numbering section, to save some screen space as we hoped it wouldn't be necessary.

Thanks for the reply Dave. I just tried that. I found it a little fiddly though and would certainly prefer this feature to be in the Bullets and Numbering section as I use a lot of lists in my work.

Still, it works! ;)

 


iMac: iMac (Retina 4K, 21.5-inch, 2017)  -   3.4 GHz Intel Core i5   -   8 GB 2400 MHz DDR4  -  Radeon Pro 560 4096 MB 

Windows: Nvidia gtx 960m 4k uhd 2gb ram video (Windows 10 Pro) -  Laptop screen (resolution 3840x2160 magnified 300%)

Share this post


Link to post
Share on other sites
3 hours ago, Dave Harris said:

Indenting paragraphs can be done with the Spacing section of the Paragraph panel. We didn't duplicate those options in the Bullets and Numbering section, to save some screen space as we hoped it wouldn't be necessary.

Of course, now that I can set my defaults (no style) the way I want them I shall change the indents your way and save it as a style. Thank you again.


iMac: iMac (Retina 4K, 21.5-inch, 2017)  -   3.4 GHz Intel Core i5   -   8 GB 2400 MHz DDR4  -  Radeon Pro 560 4096 MB 

Windows: Nvidia gtx 960m 4k uhd 2gb ram video (Windows 10 Pro) -  Laptop screen (resolution 3840x2160 magnified 300%)

Share this post


Link to post
Share on other sites
On 9/3/2018 at 10:55 AM, Dave Harris said:

Indenting paragraphs can be done with the Spacing section of the Paragraph panel. We didn't duplicate those options in the Bullets and Numbering section, to save some screen space as we hoped it wouldn't be necessary.

The trouble I'm having is when a list item runs on to a second line, is getting the left margin (assumed left aligned) of the second line to align with the first line. Ie, I want the bullet / number / letter for the list to be to the left of the left hand margin of the text.

Am I just being dumb or is this not currently possible?

 

 

Share this post


Link to post
Share on other sites
54 minutes ago, robinp said:

The trouble I'm having is when a list item runs on to a second line, is getting the left margin (assumed left aligned) of the second line to align with the first line. Ie, I want the bullet / number / letter for the list to be to the left of the left hand margin of the text.

Am I just being dumb or is this not currently possible?

You should be able to set the bullet tabstop position to be the same as the left indent.

Share this post


Link to post
Share on other sites
1 minute ago, Dave Harris said:

You should be able to set the bullet tabstop position to be the same as the left indent.

I don't seem to be able to get any of the tab setting to work within the bullet / numbering settings. Maybe I'm just not doing it right.

Share this post


Link to post
Share on other sites
38 minutes ago, A_B_C said:

I believe you will have to solve this by applying a global negative first-line indent to your list. :)

Negative-Indent.png.5503857ec83b08e2cae437e80bca87ef.png

This just doesn't seem to work for me. I have 2 problems:

  1. I can only seem to get a space between the bullet and the text by inserting spaces (can't get the tabs to work)
  2. The first line doesn't seem to be controlled in the same way you can control yours (maybe linked to above?)

See below (ignore what the text actually says):

1295780711_ScreenShot2018-09-13at15_30_26.png.6dad88fb48d0514bc47e48d29b93eedb.png

Share this post


Link to post
Share on other sites

Does your bullet text actually include a tab character after the bullet? If not, you can add one by typing \t.

If that doesn't help, can you attach a document that you think should work but doesn't?

Share this post


Link to post
Share on other sites

Here is a short video I made. It should explain the procedure quite clearly. As Dave said, it is important that you have a tab after the bullet in your settings. The presence of a tab is indicated by the blue >> icon in the Text field  of Bullets and Numbering:)

 

Tab.png.65ad4638da5c1761534d516c1f4517a5.png

 

Share this post


Link to post
Share on other sites
19 hours ago, A_B_C said:

Here is a short video I made. It should explain the procedure quite clearly. As Dave said, it is important that you have a tab after the bullet in your settings. The presence of a tab is indicated by the blue >> icon in the Text field  of Bullets and Numbering:)

Thanks for this and indeed it does work.

It turns out the problem I am facing is related to the settings applied in the text styles panel. If I try to set up a List text style, I cannot set a Tabstop distance. It defaults to '[No change]' which I presume means it is inheriting from the parent text style. 

I have now though, managed to set the style by creating the text how I want it and then updating the style to match using the drop down to the right of the style in the style panel.

Share this post


Link to post
Share on other sites

So in summary, there is a bug within the text styles settings. You cannot set up a list style directly as a new style, you have to first get the text looking how you want it and then update a style from the selected text. OK for now as a work around but it needs a fix in due course @Chris_K @MEB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×