Jump to content
Michael117

Field Functionality--Is is working yet?

Recommended Posts

Is the functionality associated with Text Fields working as expected?  I'm trying to insert a field into the text frame I added to one of my master pages, and there doesn't seem to be any Menu item to allow me to insert the field into the text frame.

Share this post


Link to post
Share on other sites

Are you in fields Panel...?

If so click on the Label to left of field you are trying to insert...It's acts as a button.

 


APh & AD 1.7.1.404 + Beta AD 1.7.2.424 | APh 1.7.1.404 + Beta AP 1.7.2.424
APu 1.7.1.404 +Beta Apu 1.7.2.422

OS:Windows 10 Pro 1903 OS Build 18362.239
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 19.06.3(Adrenalin, 
Radeon Settings Version
19.1.1) + Wacom Intuous 4M with driver 6.3.35-3

 

 

Share this post


Link to post
Share on other sites

The fields studio doesn't seem to respond to any clicks. Expanding/collapsing the categories works, but click/double-click/drag/right-click on field labels or values does nothing.


Complete Affinity suite; Mac 10.9; kbd & mouse; casual user since 2014.

Share this post


Link to post
Share on other sites
1 hour ago, hawk said:

The fields studio doesn't seem to respond to any clicks. Expanding/collapsing the categories works, but click/double-click/drag/right-click on field labels or values does nothing.

To use one of the fields in your document:

  1. Create a Text Frame.
  2. Make sure the text cursor is within the frame.
  3. Double-click on the label (name) of one of the fields in the Fields panel. Its value will be inserted at the text cursor.

-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

I do have a text frame with a blinking cursor in it, but still can't insert fields.


Complete Affinity suite; Mac 10.9; kbd & mouse; casual user since 2014.

Share this post


Link to post
Share on other sites
2 hours ago, hawk said:

The fields studio doesn't seem to respond to any clicks

A lot of the Fields will be blank until you have something to actually populate them,  example; I can insert the Section name in a text frame and there is nothing there until I actually give the section a name. Tip, open up the history Studio and watch what happens when you double click one of the fields to insert it, another tip is go to Text > Highlight Fields and check it.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1 | Affinity Photo Beta 1.7.2.146 | Affinity Publisher Beta 1.7.2.422

Share this post


Link to post
Share on other sites

I know, I'm trying to insert e.g. page number which is not blank. Nothing happens, history doesn't change, highlight fields doesn't show anything.


Complete Affinity suite; Mac 10.9; kbd & mouse; casual user since 2014.

Share this post


Link to post
Share on other sites
29 minutes ago, hawk said:

I'm trying to insert e.g. page number which is not blank. Nothing happens,

Click on the words <Page Number> and not the words Page Number: 

 


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1 | Affinity Photo Beta 1.7.2.146 | Affinity Publisher Beta 1.7.2.422

Share this post


Link to post
Share on other sites

How exactly am I supposed to be clicking it? Single click, double click, triple click? I've tried all and it doesn't work.


Complete Affinity suite; Mac 10.9; kbd & mouse; casual user since 2014.

Share this post


Link to post
Share on other sites

Make a text frame, type "Page " leave the text caret blinking and double click in the Fields Studio on the <Page Number>.

 

If that doesn't work Text > Insert > Fields > Page Number


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1 | Affinity Photo Beta 1.7.2.146 | Affinity Publisher Beta 1.7.2.422

Share this post


Link to post
Share on other sites
12 hours ago, Old Bruce said:

A lot of the Fields will be blank until you have something to actually populate them,

This is quite bad. This has bothered me for a while. We don't have any visible feedback that something has changed, unless the field has been populated earlier.

I think a better alternative would be to have some sort of <field name> inserted into a text frame and then replaced with real text when the field has been populated. This is how it works in inDesign. 

Obviously, this lack of visible feedback freaks a lot of people out.

Share this post


Link to post
Share on other sites

I'm trying to insert fields exactly like @Old Bruce with trackpad and mouse but it doesn't work. Text --> Insert --> Field --> Page Number does work, but I cannot insert total page count or any other fields from the fields studio this way.

When I click in the fields studio the text cursor stops blinking.


Complete Affinity suite; Mac 10.9; kbd & mouse; casual user since 2014.

Share this post


Link to post
Share on other sites
7 minutes ago, hawk said:

When I click in the fields studio the text cursor stops blinking.

Same here, that is disconcerting, odd that I had not noticed it before.

Some information about your system and the version of the software and what Operating System you have might help us further solve this.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1 | Affinity Photo Beta 1.7.2.146 | Affinity Publisher Beta 1.7.2.422

Share this post


Link to post
Share on other sites

APub version: 1.7.0.162
System: Mac OS X 10.9.5 (Mavericks)

I attached my System Report. Let me know if you need something more specific.

MacBook Pro.spx


Complete Affinity suite; Mac 10.9; kbd & mouse; casual user since 2014.

Share this post


Link to post
Share on other sites

It has to be the OS, your machine has better to much better hardware than mine and the only difference which I can think of is that you are running an older OS than I am. I just checked the Affinity site and there it says that Mavericks support will be added soon, but I don't know when that was written and how far along it is. So I am guessing that may be the problem for you. I am surprised it loaded at all if your OS isn't supported, the web page must be outdated.

I just had a thought, page numbers are Document specific a lot of the others are from the Operating System. So Page number, count and Section name and pages in should work can you try those?

 


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1 | Affinity Photo Beta 1.7.2.146 | Affinity Publisher Beta 1.7.2.422

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×