Jump to content

Recommended Posts

25 minutes ago, lgoodwin said:

Another "dumb as a post question." I downloaded version 238. Opened up my test publication. Using the text frame tool, selected a block of text; clicked on text, interactive, insert hyperlink. In the dialog box selected url, inserted the url in the address box and selected hyperlink format.

Returned to the document and the selected text is in blue, and underlined, as one would expect, but when I hover over the text in select mode, I get no indication that I can click on the text to open the hyperlink. Naturally, if I export the file as a pdf, there is no hyperlink exported. (Of course it wouldn't if AP doesn't recognize a hyperlink exists.)

What am I doing wrong?

test.afpub

Be sure when you export that you open the More dialog and select to export hyperlinks. Works fine for me.

Share this post


Link to post
Share on other sites
27 minutes ago, lgoodwin said:

I get no indication that I can click on the text to open the hyperlink

I don't believe you can within Publisher itself.

 

27 minutes ago, lgoodwin said:

Naturally, if I export the file as a pdf, there is no hyperlink exported.

Some PDF formats do not support hyperlinks - not just from Affinity, but at all.  Some of the PDF presets will export them and others will not.

Share this post


Link to post
Share on other sites
22 minutes ago, nwhit said:

Be sure when you export that you open the More dialog and select to export hyperlinks. Works fine for me.

Just verified that export hyperlinks was checked. Interestingly enough, a fully qualified url will successfully export.

Share this post


Link to post
Share on other sites

Thanks to all who asked for Hyperlinks and to Affinity Team for implementing them, they work and I am going to produce my next Men's Shed newsletter using Affinity

Share this post


Link to post
Share on other sites
1 hour ago, lgoodwin said:

but when I hover over the text in select mode, I get no indication that I can click on the text to open the hyperlink.

Currently there is now way to directly click onto a hyperlink to follow to it's target.

Use the 'Hyperlinks Studio' instead. Click on a link's name in the list and then on the small round button at the bottom that says 'Go to target' once you hover over it.
Note: this only works for Links inside a document, not with URLs and files.

d.


Affinity Designer 1.6.5.123 (beta 1.7.0.293) - Affinity Photo 1.6.5.123 (beta 1.7.0.293) - Affinity Designer for iPad 1.6.1.39 - Affinity Photo for iPad 1.6.8.77    ...    Affinity Publisher beta 1.7.0.293

Windows 10 (1803) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

Thank you for adding hyperlinks. :)

  • As for suggestions, I think it would be important, as other users already said, to offer the option of directly assigning a name or a custom label to a link on creation, not only afterwards in the Hyperlink Panel. Please spare us this additional step. I would wholeheartedly support what @fde101 said and demonstrated here for Quark.
  • As for bugs, my version of Publisher currently becomes totally unresponsive, as soon as I double-click a hyperlink name in the Hyperlink Panel to add a name. See my video.

Cheers, Alex

Share this post


Link to post
Share on other sites

Thanks for the suggestion to start AP while holding the ctrl key. That got the hyperlink window running. I must admit, I had never seen that option for fixing problems.

As for naming, I have discovered that if you select text that is a descriptive name for the hyperlink, that is what will show up in the hyperlink panel. If you are careful to edit the selected text you can get a more generic title for the hyperlink in the document, but the panel retains the more descriptive link you started with. Not quite like being able to directly edit the name in the panel, but it can prove helpful. In my case, I want the hyperlink the user sees to have a common name, in this case "agenda," but refer the user to a url that is different for each appearance of the link.

By the way, for me the "small round button" -- go to target, is completely non-functional.

Share this post


Link to post
Share on other sites
12 minutes ago, lgoodwin said:

If you are careful to edit the selected text you can get a more generic title for the hyperlink in the document, but the panel retains the more descriptive link you started with. Not quite like being able to directly edit the name in the panel, but it can prove helpful.

You can edit the name in the panel. Click on the entry to highlight/select it. After a brief pause (so it's not seen as a double-click) click on the text (name) in the entry, and you should be able to edit it.


-- Walt

Windows 10 Home, version 1809, 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.6.5.123 and 1.7.0.293 Beta       / Affinity Designer 1.6..5.123 and 1.7.0.293 Beta    / Affinity Publisher 1.7.0.293 Beta

Share this post


Link to post
Share on other sites

Hi Its great that hyperlinks have been added but could you do a video on how to use it , I'm trying to link a transparent shape or any shape to a specific page and can't get it to work

 

Share this post


Link to post
Share on other sites
9 minutes ago, chic said:

Hi Its great that hyperlinks have been added but could you do a video on how to use it , I'm trying to link a transparent shape or any shape to a specific page and can't get it to work

Hello @chick,

please check out this thread with some answers to your question:

Cheers,
d.

 


Affinity Designer 1.6.5.123 (beta 1.7.0.293) - Affinity Photo 1.6.5.123 (beta 1.7.0.293) - Affinity Designer for iPad 1.6.1.39 - Affinity Photo for iPad 1.6.8.77    ...    Affinity Publisher beta 1.7.0.293

Windows 10 (1803) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites
43 minutes ago, dominik said:

Hello @chick,

please check out this thread with some answers to your question:

Cheers,
d.

 

Hi Dominik, thanks for the reply but this doesn't help me, I was looking for some sort of feedback that solves the problem I'm having , I have used hyperlinks in many different programs but none quite like this , its ok for text but needs a lot of work to be fully usable, but when simply trying to link a shape to a page it just doesn't work, also in most other apps you can link once in the master and it will apply to all pages. Don't get me wrong I'm so grateful that the team are working on this and have kindly added it well before they said they would due to demand I expect, but Im thinking maybe they should look at how others are implementing it in their apps and how easy and usable it is. (just a thought).

Share this post


Link to post
Share on other sites
4 minutes ago, chic said:

Hi Dominik, thanks for the reply but this doesn't help me, I was looking for some sort of feedback that solves the problem I'm having , I have used hyperlinks in many different programs but none quite like this , its ok for text but needs a lot of work to be fully usable, but when simply trying to link a shape to a page it just doesn't work, also in most other apps you can link once in the master and it will apply to all pages. Don't get me wrong I'm so grateful that the team are working on this and have kindly added it well before they said they would due to demand I expect, but Im thinking maybe they should look at how others are implementing it in their apps and how easy and usable it is. (just a thought).

Hi @chick,

you are certainly right with your wish for more documentation on this feature.

What I want to express is that we have to keep in mind that this feature was initially introduced one week ago. It was said that this is their first take on hyperlinks. In other words, we are looking at something that is not finished. We are invited to experiment with it and our feedback is most welcome. But we just cannot expect that at the same time, when the feature set is not finished yet, we already have a documentation or video tutorials. It just does not make sense.

Again, your wish for documentation is valid. It's just that the timing has to be in the right order. First the features, then the docs.

Note: I myself several times struggled with some of the functionality of APub (e.g. tables in the beginning). After a while I found it an interesting task to figure out how this works (together with the help of other forumsters around here).

Cheers :)
d.


Affinity Designer 1.6.5.123 (beta 1.7.0.293) - Affinity Photo 1.6.5.123 (beta 1.7.0.293) - Affinity Designer for iPad 1.6.1.39 - Affinity Photo for iPad 1.6.8.77    ...    Affinity Publisher beta 1.7.0.293

Windows 10 (1803) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites
2 minutes ago, dominik said:

Hi @chick,

you are certainly right with your wish for more documentation on this feature.

What I want to express is that we have to keep in mind that this feature was initially introduced one week ago. It was said that this is their first take on hyperlinks. In other words, we are looking at something that is not finished. We are invited to experiment with it and our feedback is most welcome. But we just cannot expect that at the same time, when the feature set is not finished yet, we already have a documentation or video tutorials. It just does not make sense.

Again, your wish for documentation is valid. It's just that the timing has to be in the right order. First the features, then the docs.

Note: I myself several times struggled with some of the functionality of APub (e.g. tables in the beginning). After a while I found it an interesting task to figure out how this works (together with the help of other forumsters around here).

Cheers :)
d.

Yeh I totally get that , Its just that any conversation about hyperlinks seems to be all about linking text and nothing about shapes, hence the request for a short video to give the beta testers a start on putting it through its paces, at the moment its just frustrating me as this was number one on my wish list and I can't get to really use , just me being impatient as usual .

Share this post


Link to post
Share on other sites
34 minutes ago, chic said:

and nothing about shapes

I think I tried it on a shape only once. I'll check that out and see what I can come up with.

Good idea.
d.


Affinity Designer 1.6.5.123 (beta 1.7.0.293) - Affinity Photo 1.6.5.123 (beta 1.7.0.293) - Affinity Designer for iPad 1.6.1.39 - Affinity Photo for iPad 1.6.8.77    ...    Affinity Publisher beta 1.7.0.293

Windows 10 (1803) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

When I click on go to target in the Hyperlink studio nothing happens. Go to source seems to work consistently.  This is important to me because while I have checked the hyperlinks carefully, several of them in my test document do not function once the document is exported to pdf (and, in fact, a couple of them go to different links than are specified in the studio panel. Not sure if this is corruption in the document or a bug, so I will probably have to recreate the document from a blank document, although I will probably clear user data by doing a CTRL run up first\s, just in case.

All of my hyperlinks are within a text frame, and I have had no difficulty assigning the hyperlink to a single word within the text frame.

 

Share this post


Link to post
Share on other sites

Perhaps this will be helpful in development. I recreated the document I have been working on, and entered the hyperlinks. All worked fine, suggested that somehow the original document I had bee working on had gotten corrupted through my multiple edits.

 

Share this post


Link to post
Share on other sites
7 hours ago, chic said:

but when simply trying to link a shape to a page it just doesn't work, also in most other apps you can link once in the master and it will apply to all pages. 

Hello @chic,

I did some more testing with hyperlinks from vector objects. One targeting an email address, the other one targeting a different page in the same document. Basically this seems to work.

There is a currently problem with hyperlinks on masterpages. They cannot be assigned. Is this what you describe above?

I came across something that seems to be a bug with 'Go to Source' in conjunction with a vector object. I will post this seperately.

All in all the hyperlink feature has rough edges. But I am not surprised about that.
I am more surprised that hyperlinks have been introduced at all at this point of develoment :)

Cheers,
d.


Affinity Designer 1.6.5.123 (beta 1.7.0.293) - Affinity Photo 1.6.5.123 (beta 1.7.0.293) - Affinity Designer for iPad 1.6.1.39 - Affinity Photo for iPad 1.6.8.77    ...    Affinity Publisher beta 1.7.0.293

Windows 10 (1803) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites
11 hours ago, dominik said:

Hello @chic,

I did some more testing with hyperlinks from vector objects. One targeting an email address, the other one targeting a different page in the same document. Basically this seems to work.

There is a currently problem with hyperlinks on masterpages. They cannot be assigned. Is this what you describe above?

I came across something that seems to be a bug with 'Go to Source' in conjunction with a vector object. I will post this seperately.

All in all the hyperlink feature has rough edges. But I am not surprised about that.
I am more surprised that hyperlinks have been introduced at all at this point of develoment :)

Cheers,
d.

can you make a short vid showing how you linked the vector to another page?

Share this post


Link to post
Share on other sites
6 minutes ago, chic said:

can you make a short vid showing how you linked the vector to another page?

Sorry, I'm not good at making videos.

Please try this:

  1. Create a new document with two pages.
  2. On page 1 create a rectangle.
  3. Make sure 'View > Studio > Hyperlinks' is visible.
  4. Click once on the rectangle (to make it active) and then in the Hyperlinks panel on the page like icon next to the trash bin at the bottom. This opens the hyperlinks properties dialog.
  5. Choose 'Page' as 'Hyperlink type' (this is the default setting).
  6. In the 'Page' field type in 2 (this links to page 2). Click OK.

That is all you have to do. I hope you can follow even without a video.

d.


Affinity Designer 1.6.5.123 (beta 1.7.0.293) - Affinity Photo 1.6.5.123 (beta 1.7.0.293) - Affinity Designer for iPad 1.6.1.39 - Affinity Photo for iPad 1.6.8.77    ...    Affinity Publisher beta 1.7.0.293

Windows 10 (1803) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites
1 minute ago, dominik said:

Sorry, I'm not good at making videos.

Please try this:

  1. Create a new document with two pages.
  2. On page 1 create a rectangle.
  3. Make sure 'View > Studio > Hyperlinks' is visible.
  4. Click once on the rectangle and then in the Hyperlinks panel on the page like icon next to the trash bin at the bottom. This opens the hyperlinks properties dialog.
  5. Choose 'Page' as 'Hyperlink type' (this is the default setting).
  6. In the 'Page' field type in 2 (this links to page 2). Click OK.

That is all you have to do. I hope you can follow even without a video.

d.

Hi Dominik, that's what I have been doing except the studio part, just would not open a panel for me in studio, so I just reset the whole studio and now I can get the hyperlink panel , so I will try again to get this to work. Thanks for the speedy reply, I sure hope they will get this to work in the masters as creating a 600 page document with varying layouts would be tedious without the ability to link on the master pages , hear hoping!

Share this post


Link to post
Share on other sites
34 minutes ago, chic said:

I sure hope they will get this to work in the masters

I'm sure this will be fixed. It is reported as a bug.

d.


Affinity Designer 1.6.5.123 (beta 1.7.0.293) - Affinity Photo 1.6.5.123 (beta 1.7.0.293) - Affinity Designer for iPad 1.6.1.39 - Affinity Photo for iPad 1.6.8.77    ...    Affinity Publisher beta 1.7.0.293

Windows 10 (1803) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Share this post


Link to post
Share on other sites

@chic I also hit the RESET in Studio. Then it opened up.

 

But am I wrong in saying that the link still doesn't work. I can create it, but its not working yet? Another words if I hit it it won't take me to the address I created?

 

 

Share this post


Link to post
Share on other sites
19 minutes ago, Peter J G said:

@chic I also hit the RESET in Studio. Then it opened up.

 

But am I wrong in saying that the link still doesn't work. I can create it, but its not working yet? Another words if I hit it it won't take me to the address I created?

 

 

Links work, at least what I have tried, which are links to external url's. They don't "click" within the APub document but when exported as a pdf (with the Include Hyperlinks option selected), they do indeed click and link to the url.

Share this post


Link to post
Share on other sites

I have just completed my first Men's Shed newsletter, Mail and Web links all worked in the PDF distributed, I did not expect them to work within Affinity Publisher. Links on master page also exported.

Thanks to the Affinity Team for making links work, 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×