Jump to content

Save failed because access to the file was lost. Document must now be closed.

Recommended Posts

I would like to bump this issue with respect to affinity photo 1.6.7 on my MacBook while using Apple iCloud.  I started working on an image at home with the file stored in an iCloud folder and when it was time for me to go to work, I saved my work, simply closed my laptop, and headed in.  Reopening my machine at work, I was able to work on the (still open) image for a while longer (as long as I wanted to as a matter of fact) but lost everything when I tried to save the file.  Only later, upon executing a save, did Affinity Photo give me the aforementioned fatal error dialog (... access to the file was lost, the document must now be closed...).  Since I had saved my file before leaving my home location, I only lost my efforts while at work, so I am not going to dump affinity photo for something else that doesn't exhibit this behavior at this point, but I don't like having to have this potential issue in the back of my mind ("crap, did I save before I came here??).

I understand that there are significant technical challenges to avoiding this problem, but I should add that I do not have this issue with other software I use from day to day in which I store working copies of files at iCloud.  Also, I must add that I have only had this problem with Affinity Photo a sum total of ONCE.  But, this single event caused a serious enough loss of effort to elicit this post; I have not yet tried to reproduce it.  

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now