Jump to content
Llamallamaduck

Text flow messes up font size

Recommended Posts

I'm very impressed with Publisher Beta! I didn't have much time to test yet but I think I've encountered one problem.

I created a new text frame by clicking on the little text flow triangle of my first frame. When I wrote text into the first frame it changed size when it flowed into the other frame. So for instance I had 10pt in the first frame and 12pt in the second. So I changed the font size in the second frame to 10pt and it looked the same as in the first frame but when I deleted some text in the first frame the text from the second came back even smaller than 10pt.  

Share this post


Link to post
Share on other sites

Hey Llamallamaduck, welcome to the Affinity Forums.

Are you able to reproduce this in a new document? Do you have the affected file that you could attach? I'm struggling to reproduce this so any extra info would be fab! Thanks :) 

Share this post


Link to post
Share on other sites

View the tutorial video on Text Styles. If you use these techniques, the flow text will use the same font, colour, size and spacing. I think the styles are specific to the project and get loaded with it.

Share this post


Link to post
Share on other sites
Quote

 

I've experienced this: both the larger text and then when editing anything entering the frame in question from a subsequent frame having a smaller font size. Seems to occur if you try to connect from the existing frame, to another existing frame. In my case, when I look at the details for the the frame which has the larger text at the top of the screen after drawing, the paragraph style entry is blank. Once the text link is made, this changes to Body+ (frames with normal size text have just Body in paragraph style entry at top of screen). It isn't happening consistently.

So I think the issue is that it is possible for the style settings for the text frames to vary for for some reason. I'm not sure why. I'm not particularly skilled with this sort of software, and it's possible my work flow is periodically. File is attached in case it is helpful

untitled.afpub

Share this post


Link to post
Share on other sites

Thinking about what I did. The first few frames were present with text in. I drew the frame which ended up with the large text, and then went back to the previous frame and linked them up.

 

I've no idea why, but for some reason when drawing that frame, it came up with paragraph style entry at top of page blank. I've managed to do it more than once, but it isn't consistent. It may well be related to the order I've done things.

Share this post


Link to post
Share on other sites
6 minutes ago, kazrbutler said:

Thinking about what I did. The first few frames were present with text in. I drew the frame which ended up with the large text, and then went back to the previous frame and linked them up.

When you drew the frame which ended up with the large text, did you enlarge it by dragging on the extra handle (just outside the bottom right-hand corner)?


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iOS 12.4.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

To be honest, I can't remember. And yes that will alter font size.  But that wouldn't explain why when I first drew the frame, the paragraph style entry was blank.  And for some reason, I can't replicate that this morning.

I'm not saying that it is a bug: it may well be something caused by my clicking on the wrong things. Just having experienced it, I had just a little more information to add to what the original poster had shared.

Share this post


Link to post
Share on other sites

I'm guessing that a text frame is getting a different font size as a default - if you keep on eye on the font size when frames are being created maybe we can spot what's causing this


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.