Jump to content
CHD

Delete Key Does Not Delete Instead It Adds A Space

Recommended Posts

Hi CHD

Welcome to the forum! :)

This seems to be working for me. If I select the edge of the text frame or from the layers panel and press delete the frame is deleted. 

Share this post


Link to post
Share on other sites

CHD - yes I have this problem as well.  Totally frustrating. The only way I can delete even the one letter is to highlight it and cut.

Also experienced problems with not been able to print as mentioned elsewhere on this forum.

Having said that I think the software is amazing for first beta.

Keep up the excellent work Affinity

Share this post


Link to post
Share on other sites

I saw something similar to this when I was trying to delete a text frame that had multiple columns in it. Not sure what caused it but if I just make a new frame and add type and hit delete, it does delete the most recent character. At the same time the actual frame disappears and then reappears a second later so they've got some screen refresh bugs to work out. That might be part of what's happening here.

Share this post


Link to post
Share on other sites

If you mean that you cannot delete the text frame using the delete key (when the text frame tool is active), I think the text frames should be deleted with the select tool -  like is currently the case with Designer. As far as deleting the text in the text frame goes, that should delete without issue with the text frame tool active. For those of you having this issue, is your keyboard the full keyboard or the laptop keyboard? 

Share this post


Link to post
Share on other sites

Thanks for the thought Jane E.

The problem was not with the frame but the actual text which could not be deleted with the delete key which acted as a space bar.

I'm using an iMac with cordless full keyboard.

The weird thing is that this happened every day since I downloaded the beta but this morning I tested it again and now the delete key is working as it should, deleting text! ???

It will be interesting to see if it reappears.

Share this post


Link to post
Share on other sites
8 hours ago, jhmdigital said:

Thanks for the thought Jane E.

The problem was not with the frame but the actual text which could not be deleted with the delete key which acted as a space bar.

I'm using an iMac with cordless full keyboard.

The weird thing is that this happened every day since I downloaded the beta but this morning I tested it again and now the delete key is working as it should, deleting text! ???

It will be interesting to see if it reappears.

I also have this problem on my iMac. The backspace key adds a space to text instead of deleting. And the delete key deletes the whole text frame

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×