Jump to content

Recommended Posts

This may seem a bit odd but can you try updating your graphics drivers or uninstalling and reinstalling them. This is an issue we are currently trying to track down in our current software too, so it's not specific to this beta


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Unable to insatllI the program; I successfully downloaded the Publisher  .exe file several times, bit have not been able to get it to execute. Using Windows 7 Professional, 32-bit.

Share this post


Link to post
Share on other sites

Hi guys. Late post on this one but this was the first/best thread I found when googling 'affinity publisher not opening' - which for me is a brand new problem. Have just updated to the latest version too (after the previous recent version didn't open). New version is 1.7.0.312. The "only" change since I last opened Publisher (within the last few days) was I update my NVIDIA Geforce graphics drivers (for the first time in 2 years) to GeForce Game Ready Driver - which is v 430.64 released May 9th 2019. I'll check other posts and update this one if I find any but the problem/bug is quite simple (on Windows 10 64bit):

1. Click to open Publisher.
2. Initial loading graphic runs/loading the programme
3. The programme starts to open as usual (at least the outline shell of it does)
4. IE the menus don't load, just the outline + the close button etc
5. Within roughly 2-3 seconds (5 at the most) the progamme shell window just silently closes.
6. Closes with no warning, no message, no error, nothing. It just closes.

Running as Adminstrator makes no difference.

PS Affinity Designer seems unaffected (if this is an NVIDIA GeForce driver error). I haven't updated that for a week or three and that version number is 1.6.5.123. I'll look around now and see if I can find a more specific/recent thread on this. Thanks guys.

publisher-loading-screen.jpg

Share this post


Link to post
Share on other sites

Cross-referencing another thread for this, if that's not considered bad etiquette:

Where the reply is: "Can you please make sure you have the latest (4.7.2) .Net Framework installed?"

I don't yet know if that's what my problem is but will check that and report back here if it fixes it.

Share this post


Link to post
Share on other sites

Unfortunately, updating to .Net Framework 4.8 seems to have made no difference so any tips/clues would be highly appreciated. Let me know if there's anything I can do to surface any actual events (logs?) that I can get to you. Many thanks.

Share this post


Link to post
Share on other sites

Interesting. Extra feedback for you. I've just found out that:

1. if I click on a file directly, the file opens without any issues.
2. If I then open the/any file from within the open app then there don't seem to be any problems; but
3. If I try and open the app itself from my pinned shortcut, it fails (closes after 2-3 seconds); and
4. If I try and open any file from my pinned shortcut lists, they also fail to open (same error); and
5. If I try and open from the short-cut alias (on the desktop), it also fails (same error);  and
6. Same error if try from the standard Windows start menu
7. Which is also true if I try and open Publisher.exe file directly.

Seems strange to me (as a non application programmer) but at least I seem to be able to consistently open files directly.

Share this post


Link to post
Share on other sites

Hi @quantos,

Can you have a look in %AppData%\Affinity\Publisher\1.0 (Beta)\CrashReports\reports and let me know if there are any reports in there? If so, can you attach them?

Thanks


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×