Jump to content
mesbahworld

Can't install Affinity Publisher (bug)

Recommended Posts

Can't install . After double click nothing showing on the display !!

This is also happening Affinity Designer 1.6.5.123 , Affinity Photo 1.6.5.123 & Affinity Publisher beta-1.7.0.57.

I have Posted this problem couple of time. No one cares ...

Share this post


Link to post
Share on other sites

1.7.057I don't even get the first windows (both for Affinity Desiger 1.6.5.123 and Publisher beta 1.7.0.57) - looks like some issue with fonts according to the .log, but AD 1.6.4 installation goes without issues. 

Share this post


Link to post
Share on other sites

So here is what you do. Clean out the temp folder for your profile. Use Wise cleaner, Ccleaner or something like that and reboot. Before you load anything, load task manager, kill any startup programs that you don't need then try the install. If it does not work,, make sure it is not hung up in the task manager then RUN AS ADMINISTRATOR. and see if that does it

Also check to see if it in fact created the program folder

Check to see if the install window is running behind everything else

Check permissions on everything and if you must add your self with full permissions EVEN IF you are in the ADMINISTRATORS group with full permissions

Just had an update of windows 10? Check permissions again. Remember, they are "improving" Windows 7 into the best phone app on the market (don't get me going)

Anyway, please post back and good luck


Affinity Designer 1.6.5.135 & beta 1.7.0.258 Affinity Photo 1.6.5,.135 beta  1.7.0.258 Affinity Publisher 1.7.0.257

Windows 10 Pro 64-bit 1709

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites

Hi mesbahworld, 

Do you have any log files form the install, as talked about in this post?  If so please send them over to me in a PM and i'll pass them onto the install guys tomorrow. 

@mariocluster If you can see this link: https://forum.affinity.serif.com/index.php?/topic/64511-165-installation-issues-faq/  The font issue is covered in Point 8.  I'd suggest following the advise from Microsoft and then re-running our installer and it should install okay.  If it's still failing, PM me any error logs you have and i'll get them looked at tomorrow :) 

Share this post


Link to post
Share on other sites

Same problem here. Removed all registry entries, removed old version of Affinity Photo, manually removed all Affinity registry entries and files on the WIndows boot drive, and nothing works. Both Photo and Publisher refuse to be installed. I check the processes in Process Explorer, and both installers start up, and after a few seconds exit.

I installed two other applications today, and no problems there. So something must be wrong with the Affinity installers, or at the very least these installers are checking something that others don't.

Share this post


Link to post
Share on other sites

Same problem - run the installer and no install window appears. Setup log ends with "The type initializer for 'System.Windows.Media.FontFamily' threw an exception."

I'm not sure I'll uninstall all fonts to make the installer happy.

Share this post


Link to post
Share on other sites

Hi corvuscampus and Welcome to the Forums,

Can you follow the steps this post mainly point 8 which covers the invalid font issue.  You should then be able to install the Beta.

 

Share this post


Link to post
Share on other sites

I'm having the same issue on WIN10. Installer of AP BETA 1.7.0.57 simply does not run (or hangs).

Bones suggested deleting ' non-essential fonts' . The only fonts I have on my system are the fonts I either want or need. No way am I going to cripple my work setup to accommodate a badly mannered installer. Whether or not there is a work around  this problem speaks of a product not yet ready for market.

Also had installation issues with the old Serif Publisher in later versions which I paid for but could never get to install. 

 

Share this post


Link to post
Share on other sites

Hi petfel and Welcome to the Forums,

Please see this link and follow the steps on point 8 which cover how to find the font in question and resolve the error.

Share this post


Link to post
Share on other sites

After checking my fonts for obvious problems (invalid characters in names, bad timestamps) and not finding any issues, I went with Bones' solution - deleted every font I could remember downloading. And it worked! Thanks for the advice.

That said, having extra fonts (even imperfect ones) on a user's computer seems like a reasonable assumption about Affinity users. No big deal for the Publisher beta, but my Photo wouldn't update because of this problem too.

Share this post


Link to post
Share on other sites

I get this in UILog

Startup: 02-Sep-18 2:20:16 PM
ProductName: Publisher
ProductType: Public Beta
Opening HKLM
Opening registry key: SOFTWARE\Serif\Affinity\Publisher\1
    Failed
Object reference not set to an instance of an object.

Any help @stokerg ?

 

Share this post


Link to post
Share on other sites

All very well, but it is your softare that has the problem.

First version of Beta I have seen this problem so it must be fixable.

Surely you can fix it so we don't have to jump through all those hoops??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×