Jump to content

Recommended Posts

Hi,

Affinity Photo Windows version 1.6.5.123.

For some reason dropdown menus are opening left side, instead of right. How can I get those back to right side?

Edited by MarkoSA
Tittle spelling mistake corrected

Share this post


Link to post
Share on other sites
Can you please reset your Affinity Photo back to its default settings by holding down the CTRL key while launching Photo. When the Clear User Data window appears, click Select All and then Clear. pen.
 
Be aware that resetting your app back to its default settings will lose any custom settings such as keyboard shortcuts and brushes etc. To backup such settings before resetting the app, please watch our Affinity - Exporting User Settings and Keyboard Shortcuts video.
 
And please let me know if the issue with the menus remains

Share this post


Link to post
Share on other sites

I was able to reset Affinity Photo as you requested. Issue is still there. I took couple of screen captures after the reset, see attachments. I also closed the application and launched Photo again, no help.

Right side of the dropdown menu all sub-menus are on the left side. Left side of the dropdown menu all sub-menus are on the right side. Same session. I haven't never experienced the same problem before and been using Affinity Photo already for sometime.

I haven't done any changes on Windows settings. All the other applications are showing dropdown sub-menus right side of the menu. Not switching right-left-right etc.

Capture.JPG

Capture2.JPG

Edited by MarkoSA
Text clarification.

Share this post


Link to post
Share on other sites
16 minutes ago, MarkoSA said:

Right side of the dropdown menu all sub-menus are on the left side. Left side of the dropdown menu all sub-menus are on the right side. Same session. I haven't never experienced the same problem before and been using Affinity Photo already for sometime.

That's not an Affinity issue, but is caused by Windows, as (if I remember correctly) part of an accessibility feature for users with tablets attached to their PCs. I'm sure it's been mentioned in these forums previously, but it may take me awhile to find it.


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

I'm using PC on desktop mode. All tablet functions been turned OFF. Or do you mean drawing tablet? I am using Wacom Intuos S tablet.

PhotoShop CS5.1 is not behaving as such, just tried that.

Share this post


Link to post
Share on other sites

Yes, that's what I was thinking of. Thanks, @carl123.

However, having proposed that, I should note that my PC is set to "right-handed" but it exhibits the same behavior as shown in @MarkoSA's screenshot above. So it may simply be a behavior of Windows that the pull-downs happen on different sides, when you have a drawing tablet installed?

By the way, there's a simpler way to find that setting than shown in the thread you found: Open Windows settings, and put "handedness" in the search box.


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

You have to change it from Right to Left


Due to the ongoing Brexit negotiations, punctuation, spelling and grammar will be used sparingly until further notice.

Share this post


Link to post
Share on other sites
6 minutes ago, carl123 said:

You have to change it from Right to Left

Thanks. Also, you need to close and restart the Affinity application.


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites
7 minutes ago, carl123 said:

You have to change it from Right to Left

My bad. Thanks for this, now Photo menus seems to work logically compared to the other applications.

Share this post


Link to post
Share on other sites
3 minutes ago, walt.farrell said:

Thanks. Also, you need to close and restart the Affinity application.

Oddly, not on my Windows 8.0 PC

Changes take effect immediately


Due to the ongoing Brexit negotiations, punctuation, spelling and grammar will be used sparingly until further notice.

Share this post


Link to post
Share on other sites
2 minutes ago, walt.farrell said:

Thanks. Also, you need to close and restart the Affinity application.

Correct. That's the way how it goes. This setting change was only needed for Photo. Interestingly all the other applications were running and are still running like nothing has happened.

Share this post


Link to post
Share on other sites
3 minutes ago, MarkoSA said:

Correct. That's the way how it goes. This setting change was only needed for Photo. Interestingly all the other applications were running and are still running like nothing has happened.

The Affinity applications are aware of some things that other applications ignore, such as your monitor's color profile. This is just one more :)


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.2.424 Beta   / Affinity Designer 1.7.1.404 and 1.7.2.424 Beta  / Affinity Publisher 1.7.1.404 and 1.7.2.422 Beta

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×