Jump to content
Ian-

Affinity Photo Colour Change with DXO-NIK Plugin

Recommended Posts

When I use DXO-NIK plugin Viveza from AP I get a huge colour and tone change in the Viveza program.  If I send the file back to AP the colours are as they should be including any changes but I can't process in Viveza because I can't judge the colours their.

It appears to be a AP issue because if I access Viveza with alternative software then everything is normal.

If I change the colour profile associated with the original image the colour changes are different in Viveza. Again pointing to an AP issue.

A screen shot from AP and then Viveza are attached.  It is pretty obvious which is which.  This is with a calibrated sRGB monitor.

Latest official release of AP and Win 10 1803 updated.

Orig 16bit tiff.jpg

Viveza.jpg

Share this post


Link to post
Share on other sites
8 hours ago, Sean P said:

Hi Ian-

This is a known issue when using Viveza on a non 8-bit RGB image. I shall bump it with development.

Thanks Sean.  I can't think this is a big issue from a programming aspect and hope it will be fixed soon.

Just customer feedback but issues like this impact more on sales / "reputation" because if AP is missing some high end feature, few people will be impacted, because it is high end, and by definition "limited".  The ability to run a plugin is regarded as a basic requirement and because many more people will be impacted actually has more of an effect on AP.  Problem is programmers want to work on the "high end" features because it is more interesting. :-)  

The acquisition of NIK by DXO has generated a lot of interest in these plugins and I can imagine the "free" Google NIK plugins were not high on the programmers radar. Again, I hope you can sort this out quickly. 

Ian

Share this post


Link to post
Share on other sites

I didn't try Viveza from AP yet, but with Color Efex Pro4 (from the former free Google Nik Suite) I have more pronounced colours and effects after returning to AP than after the last filter manipulation in Color Efex before pressing "save."

Share this post


Link to post
Share on other sites

I have a similar issue with Topaz Studio and the Topaz plugins.   If I use a color space with a wider gamut the colors are shifted.  I can open a image with Wide Gamut RGB, edit it in Photo, save it as a TIFF and open it in Topaz Studio, save the TIFF, then open it in Photo and the colors stay correct.  If I take the same image and send it to Studio through the plugin the colors are incorrect.  So it appears to be a problem with passing the correct profile information using the plugin interface.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×