The short answer, no The longer answer, kinda The installer will run once you have .Net 4/4.5/4.7 installed in your Wine Prefix (used staging 3.13) and completes without any problems. Its starting it up that gets rough. The windows version of Affinity photo requires the Windows DWM for composition of the application screen and has some custom DLLs that dont seem to happy to hook into the WINE implementation of Windows. The DLLs just straight fail to load at all and while you can get it to attempt to run switching WINE to Windows 8/10 bypassing the Aero not enabled, the application crashes just after opening.   I haven't done extensive testing to get it to actually open, but truth be told you likely won't see good results even if you do. It'll likely run very unstable and slow which defeats it's entire purpose. I imagine because WINE doesn't have a complete DX11 implementation, doesn't have Windows DWM, and doesn't have/implement in full/doesn't implement the exact same any number of other necessary Windows parts it's just not going to be enjoyable. I don't know exactly how ingrained in the Windows ecosystem (dlls, etc)  the windows version of Affinity Photo is but my guess is more than WINE can deal with at this time.    Hope this helps anyone on Linux looking for an answer and saves you from wasting your time trying to get an application going in WINE just to have it run awful. EDIT: some issue could be a combo of it requiring .NET Framework and a 64bit install/Prefix. Wine can be a bit sketchy with .NET in 64bit prefixes and not all functions work running .NET application. Issues could also be arising from the rendering engine not enjoying running in WINE . Ive tried everything i ccan to narrow down exactly what issues are causing the DLLs in the program folder to not load and i have to just chalk it up to "AP needs fully implemented windows"