Jump to content
David H

Affinity Designer Crashing on both macOS and iPad Pro performing the same task!

Recommended Posts

I was following the "Create 3D Text Effect | Affiinity Designer | Tutorial | Type Mockup" on YouTube on my MacBook Pro (running macOS 10.13.6 and Affinity Designer for Mac v1.6.1 and iPad v 1.6.1) and replicating the tutorial steps on AD as I went along. However, AD hung at 2.38m in when adding/merging two layers.

I tried several times again after rebooting, removing and reinstalling AD on the mac but the issue remained.

I had just bought AD for my iPad Pro (v1.6.1 also) and tried to follow the tutorial step by step again on the iPad version of AD but it hung in exactly the same place!

Clearly there is a major issue here with AD.

Can anybody help? Affinity?



Edited by David H
Added file.

Share this post

Link to post
Share on other sites

Hi David,

I recreated that here and will pass it onto development to see if there is anything they can do to improve matters. However with that said, the method the video creator has used to create that effect creates some really bad geometry with many thousands of nodes (The font I used had created one with over 10,000). It is the calculations of all of these nodes when trying to add them together that is extremely time consuming causing the operation to appear as though it has hung.

As I said I will pass it on, but ideally the geometry needs cleaning up!

Share this post

Link to post
Share on other sites

Thanks Sean. You answer raises a number of issues...

What do you mean "the geometry needs cleaning up" and why was the user in the video able to demonstrate the feature, yet with the current AD release we can't? I should add I followed the video exactly. Surely this implies an issue with the latest release of the software?

By update, I left AD running on my MacBook Pro i7 for two days to complete the ADD action and the Activity Monitored showed AD running at over 100% whilst consuming the majority of  RAM and CPU cycles and yet it never completed the 'ADD' action. Your answer implied it would if enough time was allowed

Can you advise how I would complete the task demonstrated in the video in a more efficient and  'geometry friendly' way?

At the moment I don't know if the software is at fault, or if the task was just too huge to process in a reasonable timeframe or what? Interesting that the iPad app - same version 1.6.1 - showed exactly the same behaviour.

I'd appreciate a little clarity on the issue as  I am heavily invested in all of Affinity's products and do not want to return to Adobe apps if at all possible. Let me just end by saying that I am a huge Affinity fan and advocate.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now