Jump to content
Sarper

[By Design] [Solved] Inpainting Brush Gets Stuck

Recommended Posts

Repro:

  1. Open any document
  2. Make sure the Inpainting brush tools is elected (You can use it or not, doesn't matter)
  3. Open up a new document or new document from clipboard
  4. Select Inpainting brush tool
  5. Try to paint over the document, the inpaint operation will be added to the undo stack but it won't paint any mask and won't do anything
  6. Switch to brush paint tool, paint a stroke, return to the inpainting tool and now it works again
Edited by Sarper
It wasn't a bug after all

Share this post


Link to post
Share on other sites

Sounds like you may be initially trying to inPaint on an image layer rather than a pixel layer which will not work.

When you paint on the image Affinity will automatically Rasterise the layer for you (turn it into a pixel layer) which is why the inPainting tool works from then on.

If you right-click (the image layer in the layers panel) and Rasterise the image layer from the start the inPainting brush should work as expected


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites

You are right it's not a bug, I'm new to Affinity Photo (just migrated from Photoshop), didn't know about image layers. Thanks a lot for the informative response!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×