Jump to content
TedVDH

AD Crashes when Copy/Paste Layer

Recommended Posts

More details... the crash happens when copying from a locked layer. If the layer is unlocked, then copy/paste behaves as expected.

Share this post


Link to post
Share on other sites

Hi TedVDH,
Welcome to Affinity Forums :)
I'm having trouble reproducing this here. What type of layer are you trying to copy/paste? a vector object, text object, pixel layer...? How are you copy/pasting it? using the pop-up menu (long-press gesture) or the ellipsis menu on the top left of the app? If you could record a small clip showing the whole process it would help a lot. Thanks.

Share this post


Link to post
Share on other sites
On 7/24/2018 at 12:11 AM, Robin Raj said:

I can also confirm the same, AD crashes all the time.

 

Same here. AD (for iPad) crashes when we copy and paste a vector shape... turns all different colors - and worst of all does not save the work.

With that said, we LOVE LOVE LOVE Affinity Design. Very impressive for such a new app.

Edited by MyAmazingDiscoveries.com
Add "for iPad"

Share this post


Link to post
Share on other sites
On 7/23/2018 at 6:42 PM, TedVDH said:

I thought it was related to a locked layer, but in trying to reproduce it I think it's related to symbols instead.

FWIW, in the just released 1.6.1.40 version of Affinity Designer for iPad, I can copy & paste anything except a symbol without crashes or other issues (including copying locked layers & vectors nested inside a symbol), but pasting a symbol into another AD document crashes the app every time. It does not matter if I use the pop-up menu or the ellipsis menu on the top left of the app.

There is also what may be a related issue (or just something I am doing wrong) in that if I drag a nested vector out of the symbol in the Layers Studio so that it is un-nested while "Synch symbols" is still enabled in the Symbols Studio, it retains the vertical orange stripe in the Layers Studio & copying that now un-nested layer & pasting it into another AD document also crashes the app.

I am surprised that dragging a nested layer out of a symbol layer still links it to its previous symbol parent at all, but that is perhaps a different issue.


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites

Hello. I’m using Affinity Designer 1.7.3 on iPad Pro and, 

If a layer contains a symbol, then Affinity crashes whenever I try to copy/paste that layer into another doc. 

I’m not sure how to workaround this. Any tips?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.