Jump to content
G.J. Hunter

SVG Export - The output is a black box

Recommended Posts

23 minutes ago, mac_heibu said:

Who the hell is „dang“?

A (possibly) more polite form of another 4-letter word that begins with "da".


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.2.458 Beta

Share this post


Link to post
Share on other sites

But to be serious, Gary, I fear I hadn’t understood what your initial request was all about. How could you solve your problem by using Mystic Thumbs? Is that a thumbnail generator? How could this application solve your export issues? And how could it generate the desired thumbnail from your SVG files, when these files didn’t even contain the references to and the data of the images you had tried to embed? :o

Don’t get me wrong, I am happy to hear that it worked! But I just don’t understand why it worked … :)

Alex

Share this post


Link to post
Share on other sites

His issue was to show the thumbs in file explorer in windows after exporting to svg.
Now this is solved by a paid third party program to show the thumbs.
But the thumbs generated by ADesigner still don't show for the rest of us not using this third party program.
SVG created by other programs do show in file explorer and other programs
So the issue isn't solved at all and maybe Serif can take a look at this.


-------------------------------------------------------------------------------------------------------------------------------
Win10(1903)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites
11 minutes ago, haakoo said:

But the thumbs generated by ADesigner still don't show for the rest of us not using this third party program.

As a Mac user, I have no idea if this is relevant but in the Mac version in Preferences > General there is an option to "Save thumbnails with documents." If the Windows version has the same option & it is not ticked, maybe try ticking it & see if that makes a difference?

I have a few other apps on my Mac with a similar preference option. For all of them, as well as with any other document, I also have an OS level setting (in Finder, more or less equivalent to the Windows file explorer) to optionally show icon previews on a per folder basis. If this setting is not enabled, it overrides showing any thumbnails in Finder views, even if they are embedded in the document.

I don't know if there is anything like that for the Windows file explorer, but if there is maybe that is something else to check?


Affinity Photo 1.7.2, Affinity Designer 1.7.2, Affinity Publisher 1.7.2; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.2.153 & Affinity Designer 1.7.2.6 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.3.1

Share this post


Link to post
Share on other sites

@R C-R Have the thumbs option also in windows and ticked.
If I export the same images to svg from XaraDesigner it shows the thumbs just fine in file explorer and in other programs like XnViewMp
The svg from ADesigner itself shows in browsers but not as thumb/preview in the file explorer and XnViewMP as other svg files in the same folder do.
This third party program must be generating a thumb after the creation and not using a build-in thumb because it isn't created by ADesigner.
Hence the black box issue


-------------------------------------------------------------------------------------------------------------------------------
Win10(1903)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

So it seems the focus of this thread silently changed from empty “files” to empty “thumbnails” … thank you, haakoo, then the development of the thread makes sense … :)

Original Post: I've use Affinity for a while now, but suddenly when I export SVG, I get a "black box" as file.

Share this post


Link to post
Share on other sites

Hey thanks all for the input.

Yes, it's the "Thumbnails" in Explorer that were not showing an image, only a black box.  But when we tested again and opened the black box in Chrome the image showed.  So we knew it wasn't Affinity!  Therefore, I looked towards the Dotz SVG Explorer extension as the culprit (Remember I said PNG is fine).  Because natively in Windows it's not common to view SVG graphics as image thumbnail, it'll normally show the application icon you have assigned to it.

Dotz from Google, seems that code is old and not working again (probably based off of Windows updates).  Then I downloaded Mystic Coder for my thumbnail default app, and I deleted Dotz... and it took over all thumbnail views in Explorer.  I had to:

1.  Delete thumbnail cache in Explorer

2.  Refresh all individual files that were still showing a black box, then Mystic reassigned the thumbnail preview to it's app... and it worked.

Sorry for the confusion, it wasn't Affinity.

3. If others have this issue download Mystic Coder: https://mysticcoder.net/

There's a 14 day trial and after that its 24.  I'm on the trial so after 2 weeks we'll see if it still works.

Share this post


Link to post
Share on other sites

Just a thought, in Preferences>General there is an option Save thumbnails with documents.  Do you have this selected?


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

Yep, I had that selected.  It was the Google Dotz SVG Explorer Extension that was broken.  It just stopped working.  I think Windows update may have broke something.  The Mystic Coder worked!  I'm on the 14 day trial so I'll see if it holds, then I'll buy it.  I works for all my apps too!  Even EPS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×