Jump to content
mkdm

Affinity Designer & Photo - Issue with Copy/Paste between them and outside them

Recommended Posts

Affinity Designer & Photo - Issue with Copy/Paste between them and outside them

Hello Affinity team and thank you so much for this long awaited new tool for iPad!!!
Amazing mobile version of your flagship app for desktop!

Clearily this is the very first official version so it's normal to have some issue or some part that doens't work as excepetd.

Actually, after use it deeply for about two days, I have found one very critical issue for me.
 
CLIPBOARD COPY/PASTE BETWEEN DSEIGNER AND PHOTO DOESN'T WORK!!!
And also clipboard copy/paste of raster (pixel) objects from Designer/Photo to outside the world doens't work!!!

JUST TO BE CLEAR. I'M TALKING ABOUT THE COPY/PASTE VIA THE CLIPBOARD, NOT THE "SHARE-COPY" WORKFLOW.

This is a very critical issue for me because in my workflow I work both with Vector things and Raster things, using bitmap app for digital painting (like Procreate) and your Affinity tools.
I expected at least that the Copy/Paste command would work between Affinity Photo and Designer but I didn't find a way to make it work.
 
For example, you can easily try this very simple test:

1) Create a  simple Circle with the Ellipse tool in Designer
2) Rasterize it, so in this way it become a pixel objet
3) Copy the object into the clipboard with the "Clipboard - Copy"
4) Try to Paste into Affinty Photo. NO WAY!!
5) try to Paste into any other bitmap Apps like Procreate. NO WAY!!!

(Insted if I copy something pixels from Procreate or from any other bitmap apps to Photo/Dseigner all works as excepetd)


AND FURTHERMORE COPY/PASTE DOESN'T WORK ALSO BETWEEN DESIGNER AND PHOTO ON VECTOR OBJECTS TOO!!!

You can try it on your own easily.
1) Create a  simple Circle with the Ellipse tool in Designer or in Photo
2) Copy the object into the clipboard with the "Clipboard - Copy"
3) Try to Paste into Affinty Photo/Designer. NO WAY!!!

Please fix this serious issue as soon as possible beause it's very critical for me.

Regards.

Marco (mkdm)
 

Share this post


Link to post
Share on other sites

Hello everyone!

...I suppose that  you (Affinity Team) is a little bit busy :) but...please tell me something about this serious issue regarding copy/paste of Designer/Photo.

It's a very serious issue that is ruining my whole workflow on my iPad Pro (12.9 2017)

Regards.

 

Share this post


Link to post
Share on other sites
15 minutes ago, Sean P said:

Hi Marco,

I've reproduced this and will get it passed on to development! Thanks for letting us know.

Thanks Sean!
I hope that ASAP you will release the fix :)
Regards.

Marco (mkdm)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.