Jump to content
Lex

Export picture size change

Recommended Posts

Hello!

I need some clarification on that. What do you mean by "not positioned on whole pixels" and "alter these values slightly"?

My file was created using pixels as units, so why when I export they have one pixel more? Some times, on a square image, Affinity adds one pixel to one side (like it is 128 x 128 and the exported PNG has 129 x 128). 

In fact, I exported a bunch of artboards in Export Persona. After that I exported again just one of those artboards eliminating one element that was in the center. Both PNG came from the same artboard, but one has the size I choosed (1440 x 1080) and the other has one pixel more (1441 x 1081).

I think this is something that must be fixed.

 

Thank you.

Edited by FernandoRosa
New information added

__________________________________________

Affinity Desinger & Photo | Macbook Pro 13" Early 2015 | macOS Sierra 10.12.6 | Intel Core i5 2.7GHz | 8GB RAM | Intel Graphics 6100 1536MB

Share this post


Link to post
Share on other sites
2 hours ago, FernandoRosa said:

I need some clarification on that. What do you mean by "not positioned on whole pixels" and "alter these values slightly"?

If you look at the screenshot that @Lex posted, and examine the Transform panel (lower right of the shot) you can see that the X position of the artboard is at 7600.1 px. If it were at 7600 exactly, then it would export at the size she wanted.

When you're creating artboards you should ensure that their dimensions are whole pixels (no decimals) and that they are positioned on whole pixels. You can ensure that by running with "Force pixel alignment" enabled. (I think you'll probably also want "Move by whole pixels" disabled.)

If your artboards are positioned improperly, you can enable "Force pixel alignment" (and possibly also enable snapping; I'm not sure) and move them until they are positioned without decimal places in their X/Y coordinates. If they have an improper size you can change the sizes to fix that. Only when there are no decimal places in their sizes and positions will they export as you want.


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.3.476 Beta   / Affinity Designer 1.7.2.471 and 1.7.3.476 Beta  / Affinity Publisher 1.7.2.471 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

@walt.farrell

Thank you for the  complete information. I'll take a look when I return to the computer.


__________________________________________

Affinity Desinger & Photo | Macbook Pro 13" Early 2015 | macOS Sierra 10.12.6 | Intel Core i5 2.7GHz | 8GB RAM | Intel Graphics 6100 1536MB

Share this post


Link to post
Share on other sites

@walt.farrell

Unfortunately align the artboard in whole pixels and define artboard sizes in whole numbers makes the problem less often, but not eliminate it. Right now I think that this is really a bug...

 

 

Captura de Tela 2018-08-06 às 13.54.33 (2).png


__________________________________________

Affinity Desinger & Photo | Macbook Pro 13" Early 2015 | macOS Sierra 10.12.6 | Intel Core i5 2.7GHz | 8GB RAM | Intel Graphics 6100 1536MB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×