Jump to content
thegary

Selecting type doesn't show with some fonts

Recommended Posts

In designer i have noticed when selecting fonts for editing , the selection doesn't show on various fonts. Some do and some don't. So you are guessing as to what is selected.

Gary

Share this post


Link to post
Share on other sites

@chris_k @walt.farrell

sorry about the delay ..here are to examples..i have text selected on both screens...where you can see the type selected..its ARIAL font.

The other you cannot see its highlighted , but it is ..the font is AMTYPEWRITER mdITC. But his happens with other fonts as well...about 10 so far. Its really annoying.

any thoughts?

Gary

Designer_2018-07-10_09-31-02.png

Designer_2018-07-10_09-31-19.png

Share this post


Link to post
Share on other sites

I have no thoughts other than possibly something unusual (or broken) in those specific fonts that's somehow affecting Designer.

Possibly someone on the Serif team will know.


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.0.367 and 1.7.1.390 Beta   / Affinity Designer 1.7.0.367 and 1.7.1.390 Beta  / Affinity Publisher 1.7.0.384 Beta

Share this post


Link to post
Share on other sites

Hard to show something is actually selected when it doesn't show in a screen shot! All I can see is the frame is selected.

I think you will need to supply that file that demonstrates the issue, along with the font that is affected. 

Is the typewriter font a Type 1 font by any chance? And if so, are there two files for it installed?

I have the ITC American Typewriter Std family. But they are listed in AD differently. And do work properly.


My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites
4 hours ago, MikeW said:

Hard to show something is actually selected when it doesn't show in a screen shot! All I can see is the frame is selected.

I think you will need to supply that file that demonstrates the issue, along with the font that is affected. 

Is the typewriter font a Type 1 font by any chance? And if so, are there two files for it installed?

I have the ITC American Typewriter Std family. But they are listed in AD differently. And do work properly.

Thats the point..its is selected..and yes its very hard to work when you cannot see a selection. 

This happens with about 10 different fonts i have found.

No other programs have issues with these fonts. 

 

Gary

 

Share this post


Link to post
Share on other sites

I understand that's the point. I myself haven't faced the issue, Serif evidently hasn't faced the issue, and if you want Serif to see the problem they are going to need at least a sample file like you show above and the font to even attempt to produce it.

It may not even be font related. But if it is then they need the font you are using for the above sample and a test file it happens in.

But again, what type of font is the one above?


My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites
10 minutes ago, MikeW said:

I understand that's the point. I myself haven't faced the issue, Serif evidently hasn't faced the issue, and if you want Serif to see the problem they are going to need at least a sample file like you show above and the font to even attempt to produce it.

It may not even be font related. But if it is then they need the font you are using for the above sample and a test file it happens in.

But again, what type of font is the one above?

I have this listed in my post. The first image shows how ARIAL selects fine.

The second image shows AMTYPEWRITER mdITC and is also selected, but not showing..

Gary

Share this post


Link to post
Share on other sites

I'll leave this thread after...

It does Serif absolutely no good posting just screen shots.

They will need a copy of that exact font and it would be good to include an AD file that does this.

My versions of that font do not do what you describe. No fonts I have do what you describe. No files I have ever created do that with any of my fonts nor the fonts I have received from other users.

If you want Serif to investigate this they need the font you show and a file as created on your system.


My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites

Hi thegary

I;m not able to get this at all with any of the fonts that I have installed. Would you be able to upload some of the fonts that are giving you this issue using this link so I can look at trying to replicate this?

Thanks


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×