Jump to content

SVG turns into images, why?

Recommended Posts

For some reason, some SVG elements keep turning into images? The file I have uploaded is part of a bigger illustration. However, whenever I export it as an SVG it turns into a png (i think) and the quality is terrible. I have opened the file up in Brackets a free Adobe code editor and reading the code you can see it's a PNG. Is there a workaround? 

I have also included the greater picture (not finished) and it looks like everything below the eye level is images.

Thank you very much for your prompt response. I have noticed that this has been happening all the rime but now I'm turning pro and it can't continue really. 





Edited by psocretes
Updating files as requested.

Share this post

Link to post
Share on other sites

Thank you. I'm learning how to make SVG elements animatable and interactive on triggers for webpages. The idea is that different things (animations) happen on scroll and mouse events. 

Share this post

Link to post
Share on other sites

Hi psocretes

This is being rasterised due to the layer transparency you are using on the planks (and possibly other places) SVG doesn;t understand layer opacity, more colour opacity so it is rasterised to preserve the look. You can work around this by setting the layer opacity to 100% and using the opacity slider on the colour panel instead


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.