Jump to content
dotfuz

Crash when trying to change font

Recommended Posts

Hi all, referred here from Twitter.

On Affinity Designer, whenever I'm trying to change the font after using/selecting text I created using the Artistic Text Tool, the app keeps crashing. I see the little rainbow umbrella every time immediately after I've clicked the drop-down arrow and it stays until I force quit the app. I tried leaving it for an hour and it just stayed the same.

I've tried:

-restarting my Mac

-checking Font Book for any custom fonts in the User menu and there are none

-new documents

-existing documents

And the same issue is occurring. 

I've also tried using one of the other user accounts (which actually has many custom fonts installed in the User section of Font Book) and funnily enough everything works perfectly on that account.

I have the administrator account and can't delete it because there's just too much on it. Please let me know if there's any information I can provide such as specs of my device, etc. I'm running the latest versions of macOS and Affinity. 

Share this post


Link to post
Share on other sites

Hi dotfuz,
Welcome to Affinity Forums :)
Are you using a 4k/5k monitor? If so, do you have your monitor settings set to More Space in the System Preferences, Display section? Change it to Native (or scaled) and check if you are still experiencing this please. This is a known bug that we are looking into.

Share this post


Link to post
Share on other sites

Thank you so much MEB! That did the trick! 

I use a MacBook Pro and use RDM to change the resolution to 2880x1800, as soon as I did as you recommended the fonts worked perfectly immediately. The other user account has a lower resolution setting than I do so that's why it was working fine for them.

Is there a reason why this happened recently? I opened up AD after a few months and I know for sure it used to work fine at the resolution I had it set to. I can keep changing my resolution back for now but with the workload I have coming up it'd be nice if it gets sorted soon! I'm sure you all have lots of other more important things to fix first so I'll be patient.

Thanks again, I really appreciate it. 

Share this post


Link to post
Share on other sites

I have just experienced the same issue, following this and choosing one level down on scaled has made it work. Please keep investigating so I can return to normal scale. If I can be of any help, please do let me know.

Thanks

Share this post


Link to post
Share on other sites

Also waiting for an update on this, it's still happening mid-August. I've just bought a new 4k monitor for my MacBook Pro for design work and this is a major dealbreaker with Affinity if this isn't fixed quickly :/

Share this post


Link to post
Share on other sites
On 6/21/2018 at 11:29 AM, MEB said:

Hi dotfuz,
We are still looking into this issue. Although we have some clues already it's not yet clear what's going on.

This is a real pain! Freezing my AP every time I want to sign a photo prior to publishing on the web. Output and enjoyment SERIOUSLY affected.

It seems to have been happening for a long time.  Any news ??


MacPro (late 2013), 24Gb Ram, D300GPU, Eizo 24",1TB Samsung 850 Archive, 2x2Tb Time Machine,X-t2 plus 50-140mm & 18-55mm. AP, FRV & RawFile Converter (Silkypix).

Share this post


Link to post
Share on other sites
On 6/19/2018 at 4:02 PM, MEB said:

Hi dotfuz,
Welcome to Affinity Forums :)
Are you using a 4k/5k monitor? If so, do you have your monitor settings set to More Space in the System Preferences, Display section? Change it to Native (or scaled) and check if you are still experiencing this please. This is a known bug that we are looking into.

Tried all scaling sizes to no avail?


MacPro (late 2013), 24Gb Ram, D300GPU, Eizo 24",1TB Samsung 850 Archive, 2x2Tb Time Machine,X-t2 plus 50-140mm & 18-55mm. AP, FRV & RawFile Converter (Silkypix).

Share this post


Link to post
Share on other sites
4 hours ago, Sharkey said:

Tried all scaling sizes to no avail?

Signing with 'Place' now with a premed signature.

Would like to use a brush but not able to create one at the moment - the method is a bit beyond me. All the explanations leave me more confused than enthused.


MacPro (late 2013), 24Gb Ram, D300GPU, Eizo 24",1TB Samsung 850 Archive, 2x2Tb Time Machine,X-t2 plus 50-140mm & 18-55mm. AP, FRV & RawFile Converter (Silkypix).

Share this post


Link to post
Share on other sites

I have the same hang in AD opening up fonts. I have a quad core mini with 4k monitor. From the forums I see that this has been a known issue as far back as April and still is not fixed. That is really embarrassing and does not inspire confidence. 

Share this post


Link to post
Share on other sites

Just wanted to add that I have been having this issue since I got my 4k monitor roughly a year ago. Not sure why this is happening. When I am on default for monitor or anything with higher resolution than the middle setting on scaled, it will crash anytime I click to change fonts. I have been relegated to adjusting my resolution on my monitor anytime I need to create a graphic with words. I would love to be notified when this issue get resolved. It is a pain to change back and forth all the time. I love affinity, but this is a big problem. 

Share this post


Link to post
Share on other sites

Had the same issue, and wrote in an other post about it. Thanks to earlier replies here I tested to change the resolution with my 4K display. So I changed the screen resolution to 1080 and it worked without any problems. After this I set it to 4K again and yeeah its still running. Thats a nice trick, but still confused why my display resolution is able to crash AD. This should get a fix in the next version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×