Jump to content
koda1000

Sampling color with the Brush while using a Pen does not work.

Recommended Posts

I am using Windows 10 version 16299.461 on a Microsoft Surface Pro 4. I am attempting to use the brush tool to paint and every so often press the alt key to temporarily switch to the eye-dropper tool to sample some color and then return to the brush tool by releasing the alt key so that I can continue painting with the newly sampled color. This works correctly while using a mouse but does not work at all with the pen (stylus). When I press the alt key and tap with the pen, the color that is picked up is the color directly underneath the mouse pointer (where the mouse/touchpad was last left resting) rather than where the pen is actually tapping. Therefore, I can not ever sample a color while using the stylus. If I can't figure out how to get this to work with Affinity Photo then there is no point in using Affinity Photo. This is a major part of my workflow and I can not use a mouse, that is far too slow and clumsy.

Am I missing something? Is there a setting I need to turn on? Or is this a bug?

(Edit) I can't even use the eye-dropper with the pen (stylus). Each time I tap the screen with the pen tip the picked color is the one where I last used my laptop touchpad. I was hoping I could alternate between pressing "I" and then tapping a color with my pen and then pressing "b" to begin brushing; repeating as necessary. But I can't do that. It is as if Affinity Photo is ignorant that I am using a pen.

Share this post


Link to post
Share on other sites

Hi koda1000

Thanks for raising this I have passed it over to the development team. The issue with  using the colour picker tool itself with the surface pe is also an already knonw issue

Thanks 


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Hello, it is now Sept 11th 2018, I have now installed the newly released Affinity Photo 1.6.5.123 and this issue still persist. On June 19th, Chris J said that it was fixed in beta. I imagine that the then beta has by now been rolled into this stable release (1.6.5.123). Yet eye dropper sampling with a pen (surface pro 4 pen) does not work. The problem remains exactly as I had described originally as topic creator.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.