Jump to content
EmeraldSlash

(Designer) Keyboard input being ignored for most hotkeys

Recommended Posts

After a while in Designer, keyboard input for hotkeys (e.g. P, Ctrl+J, Ctrl+S) and Art/Frame text input do not work. Keys like Shift/Ctrl when transforming an object in the viewport still work, as well as zooming using Ctrl+Scroll, and property text input (e.g. names, transform values, brush size, etc.) still work.
I've noticed that this is usually preceded by Designer freezing for a couple of seconds, and then once it resumes the issue starts. The issue can be fixed by restarting Designer, until it freezes again.

Note that this issue only happens on this specific laptop and not on my Windows 10 and Windows 7 desktops. The issue has started recently - in the last one or two updates most likely.

My specs:

Windows 10 x64 Laptop
Intel HD Graphics 620 & NVIDIA GeForce 940MX
Intel i5 7200U Quad Core

Share this post


Link to post
Share on other sites

Hey EmeraldSlash,

Is the laptop also on Windows 10? Do you know if it has had the 1803 update? We've seen a few users report a host of issues after this update—although this is the first time I've seen anyone report an issue with shortcuts.

It might be similar to an issue we've fixed in our beta, where certain actions can cause shortcuts to cease working. Can you try installing the beta on your laptop and see how you get on? Here's the link:
https://forum.affinity.serif.com/index.php?/topic/58648-affinity-designer-customer-beta-165109/

 

Share this post


Link to post
Share on other sites
13 hours ago, Chris B said:

Hey EmeraldSlash,

Is the laptop also on Windows 10? Do you know if it has had the 1803 update? We've seen a few users report a host of issues after this update—although this is the first time I've seen anyone report an issue with shortcuts.

It might be similar to an issue we've fixed in our beta, where certain actions can cause shortcuts to cease working. Can you try installing the beta on your laptop and see how you get on? Here's the link:
https://forum.affinity.serif.com/index.php?/topic/58648-affinity-designer-customer-beta-165109/

 

Yep, it's Windows 10. The last update I had was 1803, so I guess that's probably what caused it.

I'm trying out the beta now and will let you know how it goes.

Share this post


Link to post
Share on other sites
15 hours ago, Chris B said:

It might be similar to an issue we've fixed in our beta, where certain actions can cause shortcuts to cease working. Can you try installing the beta on your laptop and see how you get on?

I've been using it for about an hour now and haven't had the issue. Looks like the beta has fixed the issue :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.