Jump to content

Recommended Posts

Affinity photo is hanging, and I don't know what's causing it.  I have had similar freezes happen in the last few weeks of using it too.  Not many, but even just one every few days of use is enough to disrupt workflow.

What I was doing:

  1. Merged down the attached file onto a single layer.
  2. Made visible only the merged down layer.
  3. Went into develop mode on the merged down layer, and started making adjustments (shadows and highlights, contrast, etc)
  4. Pressed the split view button so that I could compare the image before and after adjustments.
  5. AFFINITY HANGING!

My setup:

  • 64-bit
  • Windows 10 
  • 8GB RAM
  • Affinity Photo 1.6.4.104

So, interestingly, it's not showing as "not responding", but if I click on the Affinity Photo icon, it doesn't bring the window up, it just shows what was there before.  Task manager lists affinity photo, and that it is consuming 2GB of RAM (RAM usage in total running at 70%), but not using any processing power. Attempting to close the application by right clicking on Affinity Photo and pressing close window doesn't seem to do anything.

So instead I have closed the application by using "end task" in the task manager.

After re-opening the file, and doing the process again, it proceeded without hanging.

Nick at drawing board.afphoto

Share this post


Link to post
Share on other sites

Hey Aristocrates, welcome to the Affinity Forums.

I'm having a hard time trying to reproduce this. I've done exactly as you've said but it's absolutely fine. Can you go to Preferences > Performance and screenshot your settings so I can match them?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×