Jump to content
DanielM

Affinity Photo/Designer won't open

Recommended Posts

Affinity Designer used to work fine. I purchased and installed Affinity Photo. Now neither program will launch. When I run them, I get a brief "loading" cursor and then nothing. If I open Task Manager, I can see the application running for a second, then it disappears. No error messages and nothing in the Windows logs. This is on Windows 10 Pro.

Any advice?

Share this post


Link to post
Share on other sites

Hi DanielM

 

Has anything changed recently on your system such as a Windows update? If you run a repair on the apps or reinstall them entirely do they start to work again for you?

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Is there any hope of getting some support on this? I purchased this product and can't use it. Is there somewhere else I could be contacting the support team?

Share this post


Link to post
Share on other sites

When you installed Photo, did you install to the default directory, or did you override the installer's dialog and try to install to the same directory you installed Designer into?


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.499 Beta

Share this post


Link to post
Share on other sites
17 hours ago, DanielM said:

Nope, its completely empty.

 

The very first thing we try to do is create a log file in that directory, so if it's empty, it means that our application hasn't even started running yet. This indicates some problem with dependencies on your machine. Perhaps a corrupted .NET installation. 

Share this post


Link to post
Share on other sites

Affinity is the only application not running properly on the machine. I have many, many other programs which operate fine and are based on .NET, including some .NET development applications. What do you suggest for debugging?

Share this post


Link to post
Share on other sites

It's been two weeks since I bought this software and still unable to use it. Is there a better support system through Affinity or am I stuck waiting around for you guys to respond to my forum posts?

Share this post


Link to post
Share on other sites

Hey DanielM,

I've seen a few other users report the app simply will not open. There are a few things I know of that might be causing this:

  1. Windows updated to 1803 which seems to have caused the app to stop opening or the UI isn't loading. See if you can roll back or uninstall any Windows KB updates since you began having the issues
  2. You have Duet Display installed. Install version 1.4.7.6 or later
  3. You're working with a Surface and have a high-res monitor connected to it. Try disconnecting the monitor
  4. Graphics driver. Completely uninstall your graphics driver and do a fresh install. Don't just do an update on the top of the existing one

Share this post


Link to post
Share on other sites

Chris,

1. Windows is on 1511, so that's not an issue

2. Don't have Duet Display

3. Not working with Surface.

4. Completely uninstalled graphics drivers. Still does not start.

Share this post


Link to post
Share on other sites

For anyone who comes across this issue, I went ahead and solved this myself by updating Windows 1511 to 1803.

Here's hoping your product is better than your support system.

Share this post


Link to post
Share on other sites
1 hour ago, DanielM said:

For anyone who comes across this issue, I went ahead and solved this myself by updating Windows 1511 to 1803.

I was going to say: version 1511 is pretty old now! Was there a particular reason why you held back from updating for so long?


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iPadOS 13.2.2 (iPad Air 2)

Share this post


Link to post
Share on other sites
8 hours ago, αℓƒяє∂ said:

I was going to say: version 1511 is pretty old now! Was there a particular reason why you held back from updating for so long?

I was also going to say: I'm sure 1511 is almost 3 years old! 

I'm glad you sorted it @DanielM

Share this post


Link to post
Share on other sites
5 hours ago, Chris B said:

I was also going to say: I'm sure 1511 is almost 3 years old!

Quite so, Chris! 15 => 2015; 11 => November. ;)

 


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iPadOS 13.2.2 (iPad Air 2)

Share this post


Link to post
Share on other sites

I have similar problem, I think.

I want to buy Affinity Designer, so I install trial version to see how It works on my computer, but when I try to open it's crashing. AD is openning normally, but when it goes to part of creating new document and I try to do it, some error appears. Look on photo below. I tried to reinstall trial but all the time is the same.

I guess that it may be caused by windows actualization, but I'm not sure. Have you any idea how to resolve this problem? 

image.thumb.png.0e21211bb9211cf2acc28fdfacd84699.png

Share this post


Link to post
Share on other sites

Hi @Kreatoria, welcome to the Affinity Forums.

Have you made sure than your graphics drivers are up to date and that you're running the latest available version of Windows? Sorry if you've already tried this but you didn't mention it.

I'd like to get this sorted for you as soon as possible so you get chance to enjoy the trial. Can you tell me what your PC specs are? Do you know what Windows scaling settings you are using? 

Share this post


Link to post
Share on other sites

I have same problem, all of a sudden it wont open after updating to 1.7.3 so I reverted back to 1.7.2 which I knew worked but that is same wont open. Ive uninstalled again and loaded my first version 1.6.4.104 and this is same, just cant get Affinity to load up anymore??

Share this post


Link to post
Share on other sites

I've reverted back to an old disk image which has windows 1809 build 17763.805 and infinity works. I was on 1903 build 18362.10022.

Just have to wait now for windows updates to make it stop loading again maybe??

Share this post


Link to post
Share on other sites

Hey Spider_Webster,

Were you crashing on launch? Usually that's either a driver issue with your video card and we would recommend uninstalling it and reinstalling it (don't just update) or check the list of known software conflicts:

https://forum.affinity.serif.com/index.php?/topic/44770-issues-caused-by-third-party-software/

The old disk image may not have any of those applications installed on it which is why it is working.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.