Jump to content
LR0728

Can't print multiple images Affinity Designer

Recommended Posts

We are printing labels to a LX900 label printer, and when sending a print job with multiple copies, the printer will only print one copy.  We just started using affinity, so it's not worked at any point for printing.  Previously on Drawplus with same printer and not this problem.

 

2018-05-14_9-32-52.png

Share this post


Link to post
Share on other sites

Hey LR0728, welcome to the Affinity Forums. 

 

Can you attach the file? I've successfully printed a shape on 10 A4 sheets (copies) without any issues. I'd like to see how your document is set up and see if I can print it. 

Share this post


Link to post
Share on other sites

Thanks for the file. It prints fine here, which I expected. It's definitely a printer/driver related issue. Modifying an ini file would be something dev would need to look at with me so I can't provide an answer for you just yet. I'm waiting to hear back from the dev team.

Share this post


Link to post
Share on other sites

Hi,

When printing, we ask the Printer Driver if it can manage multiple copies itself. If it says it can then we send the job once with the number of copies required. If it says it can't, we send the job multiple times, but this is less efficient which is why we try to avoid it.

It sounds like we are asking the driver, it is telling us it can do multiple copies but then is not honouring the request. I suspect the Corel workaround avoids the initial query and just sends each job multiple times. Unfortunately we do not have any configuration option like this.

Are there any 'Number of Pages' setting in the print driver? Many do, and whilst slightly more inconvenient, it would probably be easier to use that than print multiple times. Please also check there are no other driver settings that could be causing this problem.

 

Share this post


Link to post
Share on other sites

Hi,  Thanks for the info.   I don't know that I believe it's a printer/driver issue. 

No, there are no other printer driver settings.  From Serif Drawplus, we print multiple copies every single day to the SAME LX900 printer.  So really, it's pretty clear that it specifically relates to the Affinity product, from my point of view.  I still use Drawplus side by side with Affinity every day as we're transitioning, and only Affinity won't print multiple copies. Please will you check more? 

Share this post


Link to post
Share on other sites

HI Adam - I hope a solution is coming soon.  It's been slow production printing one file at a time every day.  Please advise a status update.  Thank you!

Share this post


Link to post
Share on other sites

Hi LR0728, until Adam can find a solution, couldn't you export the file to a PDF and print multiple copies from there? It might save you a lot of time for the inconvenience of exporting and then printing from Acrobat. 

Share this post


Link to post
Share on other sites

Hi Chris,  No that wouldn't save any time. We open and modify 30-50 files a day to print mutliple labels.  They require changes to a production date every day.  So no, making a new pdf for every label every day doesn't save time.  Thanks for trying.

Share this post


Link to post
Share on other sites

Hi Team at affinity!  I am really looking for a solution to this problem.  It's bee very tedious printing our daily production labels one at a time for 3 months.  Please will you kindly advise ?

 

Share this post


Link to post
Share on other sites
1 hour ago, LR0728 said:

HI Affinity.  Here we are in October now, and not a word of help on this issue.  Can anyone resolve?

 

Have you tried contacting the manufacturer of the LX900 label printer to see if they are going to fix their driver?

Share this post


Link to post
Share on other sites

Yes, we have contacted Primera LX900 again TODAY and walked through all possible settings, drivers, permissions. They say that the problem is with Affinity Designer, not anything to do with the printer.  The printer works fine from any other program.

 

Share this post


Link to post
Share on other sites

Hi LR0728,

There may be a potential fix in the 1.7 beta so you can keep an eye out for that and give it a shot. As with any issue we cannot reproduce, it's potentially difficult to fix. I'm not sure if it's worth trying our Affinity Publisher beta to see if that allows you to print multiple images.

https://affinity.serif.com/en-gb/publisher/

 

Share this post


Link to post
Share on other sites

What's the timing for the release of the 1.7 beta?  Also, I'm not really interested in yet another new program (publisher).  It took us months to rebuild files from Drawplus to Affinity.  We'd like to see Affinity working as I think it should - allowing us to print multiple copies.

Share this post


Link to post
Share on other sites
11 minutes ago, LR0728 said:

Yes, we have contacted Primera LX900 again TODAY and walked through all possible settings, drivers, permissions. They say that the problem is with Affinity Designer, not anything to do with the printer.  The printer works fine from any other program.

Well, that's not strictly true, as you pointed out earlier, CorelDRAW didn't work either, and required setting a special mode to emulate the multiple copies option (by sending the same job multiple times). http://kb.primera.com/article/21426/44678/lx-series-printer-prints-only-one-copy-of-a-multiple-copy-job-and-then-stops-when-printing-from-corel-draw-lx400800810900

We will look at adding a work around for this print driver.

Share this post


Link to post
Share on other sites

I agree with you regarding the CorelDraw, but I have tried multiple times with Primera and they can't provide any further assistance.  I will appreciate you adding a work around. We really need to get this resolved as it's slowing down our daily production of coffee labels (and you know how people get when they don't get their coffee!).

Share this post


Link to post
Share on other sites
15 hours ago, LR0728 said:

What's the timing for the release of the 1.7 beta?  Also, I'm not really interested in yet another new program (publisher).  It took us months to rebuild files from Drawplus to Affinity.  We'd like to see Affinity working as I think it should - allowing us to print multiple copies.

I wasn't suggesting you used Publisher instead. I was hinting that there may be a fix in Publisher so if that works, you can safely assume that the updates to Designer will work. If Publisher doesn't work, we have an early heads up.

Share this post


Link to post
Share on other sites

Ok, I understand.  I downloaded the beta version of publisher, created a file, selected to print 3 copies, and unfortunately, it only printed 1 from the print job.  It is behaving just like Affinity Designer.  I attempted a couple different things, but the result was the same - only one copy printed from a multi copy print job.

Share this post


Link to post
Share on other sites
45 minutes ago, LR0728 said:

Ok, I understand.  I downloaded the beta version of publisher, created a file, selected to print 3 copies, and unfortunately, it only printed 1 from the print job.  It is behaving just like Affinity Designer.  I attempted a couple different things, but the result was the same - only one copy printed from a multi copy print job.

Thank you for trying that. That is very disappointing to hear and a little bit surprising. Would you be able to attach, link or send me the print driver for the Primera LX900? 

Share this post


Link to post
Share on other sites
1 hour ago, LR0728 said:

Sure thing.  Here is the link to Primera LX900 print driver v 1.07 and PTStatus Monitor v1.2.8.  We use the PC version.  https://www.primera.com/lx900#software-target

Thank you. We will try an alternative fix in the next Publisher Beta. We've just released 157 so not that one, but the next one. Any fix we do make in Publisher will end up in Designer when it is released.

Share this post


Link to post
Share on other sites

Hi LR0728,

We've just released an updated Publisher Beta here. If you would like to try it, please install and run it with the command line argument:

--printmode1

(that's a figure one on the end there). I normally add switches like this this by creating a desktop shortcut and adding the switch to the end of the 'Target' field. 

Running with the switch will enable a printer workaround that we hope will fix your problem.

----

Also - it would help us out if, after printing with the app, you could let us have the application log file which is created here:

%appdata%\Affinity\Publisher\1.0 (Beta)\Log.txt

You should be able to paste the above into the address bar in Explorer to find or open the log file.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.