Jump to content
JMEdinburgh

Can't open any file (RAW or JPEG) in Affinity Photo

Recommended Posts

1 hour ago, walt.farrell said:

No. You can just start typing after pressing the Windows key. It will perform a search as you type and display a list of possibilities for you to select from.

Indeed you can!  Never come across this before!  Many thanks @walt.farrell


Win 10 Pro, i7 6700K, 32Gb RAM, AMD Radeon R7 360 and Intel HD530 Graphics

 

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer and Photo; looking forward to Affinity Publisher.

Share this post


Link to post
Share on other sites
9 hours ago, Chris B said:

@kbach That log has shed a bit more light on things and I've been advised to ask if you can uninstall your current graphics drivers and then do a fresh install. Don't just do an update.

Hi Chris & @Mark Ingram

 

Thank you for your help and direction in troubleshooting the issue related to my Intel HD graphics 3000 card/driver and its questionable compatibilty with DirectX 12.  My laptop is a Lenovo W520 and I now realize it has a second graphics card, being a NVidia Quadro 1000m.  With that newfound awareness, I updated its driver and did my best to set the 3d settings to play well with Affinity Photo. 

 

Next, in Preferences > Performance > Renderer, I selected the Quadro 1000m, restarted program, and guess what ..... No Luck!  Ugghhh!!!! The same unhandled exception error.  

 

However ...... with nothing to lose I chose the last Renderer option "Microsoft Basic Render Driver" ........  and a beautful thing happened, my file OPENED!!!!

 

Any thoughts on why the generic option worked to open a file when the dedicated selection(s) failed?

 

 

Share this post


Link to post
Share on other sites
3 hours ago, Mark Ingram said:

Hi @kbach, thanks for that. The basic renderer will be a lot slower than an actual GPU. We require feature levels 11.1, 11.0, 10.1, or 10.0. From your screenshot, it appears your card supports it.

 

Ok, at least I'm up and running until I can (hopefully) get the NVidia card to work.  When you say feature levels, is that in reference to DirectX?

 

What action do you think might correct the memory resource error (card stats below) when attempting to load the Quadro 1000m as my Renderer?  The NVidia 3D Settings options menu is also attached below with so many options, it leaves  me bug eyed: 

 

LOCAL ERROR LOG

    -- 2006.563206ms
WinTab: Failed to load Wintab32.dll
WinTab: Failed to create tablet context
Attempting to create Direct3D device with adapter NVIDIA Quadro 1000M
DXRenderer.cpp(822): error 0x8007000E (Not enough memory resources are available to complete this operation.)

Screenshot (1).png

Screenshot (3).png

Share this post


Link to post
Share on other sites
On 5/17/2018 at 11:30 AM, Chris B said:

I think your issue is separate to the one that Wosven has posted. I'll split it into a second thread—I'll split the posts later.

It seems as though you *might* be getting a crash within DirectX. The crash report isn't really telling us much else. So this is very likely a driver issue. Can you please try and update your graphics drivers. If you want to provide a dxdiag it might help:

  1. Press Windows key + R on your keyboard
  2. Type in the box the following: dxdiag
  3. Click Save all information
  4. Attach the text file 

Once we've ruled out a possible driver issue, we can look at what to try next. You can quickly test the graphics driver theory by going to Preferences > Performance > Renderer > WARP.

 

Hi Chris,

 

This has worked, well the file opened without the program closing

 

Many thanks

Share this post


Link to post
Share on other sites

@JMEdinburgh you may want to still see if you can address a potential issue with your graphics drivers. I'm not sure if you did manage to update them at all? Could be worth uninstalling them and re-installing them as opposed to just updating them. 

You will find WARP can be somewhat slower than using a dedicated card. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×