Jump to content

Recommended Posts

I just purchased Affinity Photo and am seeing issues already.

 

Brush import is not working properly/well.

 

1) Brush shape in AP ties to brush roundness in PS.  Brushes imported into AP with a certain roundness retain the setting value under the Shape parameter.  However the Shape parameter in AP does nothing. You can move the Shape setting from left to right and roundness/shape of the brush is unaffected. I have a cloud brush (attached) with a roundness of 36, it looks properly squashed in PS, it is unaffected and full size in AP.  Assigning the value upon import indicates that the Shape parameter should do what the Roundness parameter does (otherwise why import the value?) but the FUNCTION of the Shape parameter is not the same as the roundness function in PS.

2) PS has functionality where a control like Rotation is set with a value of 0 for control based upon direction but it still functions (as long as some control type is assigned to the control).  In AP, the value imports as 0, but a zero value shuts off the dynamic even if a control type is assigned.  In order to get proper behavior, export should not disable the dynamic if a control type is assigned but the control value is 0, and should only disable the control if the control type is None.

3) Resetting the brush values doesn't set them back to original imported default values. 

4) Import of the "spacing" value needs to be adjusted (see attached PSD) to achieve similar results to a brush's performance in photoshop, or maybe this is caused by #5:

5) Flip X jitter and Flip X jitter aren't present in AP.  There is no substitute that I can see in any of the brush settings that will give the same effect. Brushes with this characteristic checked in PS behave very differently in AP.  This kind of randomness is essential in order for a foliage brush or a cloud brush to look natural by avoiding repetition. (See cookie-cutter effect in attached photoshop file.)

 

I attached brush files (imported and original) and a PSD file showing AP behavior vs PS behavior. The differences are night and day and the brush import is not usable in its current state.  In the PSD, the AP brush behavior is above and the PS behavior is below.  

 

 

BrushBug.psd

Bug Brushes.afbrushes

OneCloudBrush.abr

Share this post


Link to post
Share on other sites

I created this post Sunday night. It is Tuesday afternoon and there is no response. This forum is the form of support users are directed to and as far as I know there is no other.

 

I’ve now requested and received a refund on both the iPad and MacOS versions of Affinity Photo. 

Share this post


Link to post
Share on other sites
9 minutes ago, MikeInProcess said:

I created this post Sunday night. It is Tuesday afternoon and there is no response.

 

Yesterday (Monday) was a bank holiday here in the UK.

 


Alfred online2long.gif
Affinity Designer 1.6.5.123 • Affinity Photo 1.6.5.123 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.6.12.86 • Affinity Designer for iPad 1.6.4.45 • iOS 12.2 (iPad Air 2)

Share this post


Link to post
Share on other sites

Hi MikeInProcess

 

Sorry you did not get on with our brush implementation. Being a different app we are going to do things slightly differnelty to PS and the abr format is an Adobe format not ours so we can only import so much from it accurately, it is difficult to get every aspect. I will pass on any points i feel are bugs to our devlopment team to look into improving as well as your general feedback

 

Thanks


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×