Jump to content
nj36

Affinity software wont open

Recommended Posts

Both Affinity Photo and Designer suddenly wont open. I was using them both a fortnight ago without any issues. But when I tried to open them today they appear in my task manager for a second before disappearing. I've tried uninstalling and then deleting all Affinity folders and files that are left behind before downloading and reinstalling. But this hasn't worked. They appear to have installed properly, just nothing happens when I try to open them.

 

I don't have any of the third party software installed with known issues or any third party antivirus software. I've also not installed any software since I was last using Affinity software and everything else seems to be launching and running as normal. 

 

Any help would be appreciated!

Share this post


Link to post
Share on other sites

Welcome to the Serif Affinity Forums, @nj36. :)

 

Try clearing your user data. Press the Ctrl key, keep it held down while you launch the app and continue to hold it down until the ‘Clear User Data’ dialog appears. Release the Ctrl key and press the ‘Clear’ button in the dialog.

 

If the above fails to fix the problem, try again but press ‘Select All’ before pressing ‘Clear’.


Alfred online2long.gif
Affinity Designer 1.6.5.123 • Affinity Photo 1.6.5.123 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.6.11.85 • Affinity Designer for iPad 1.6.4.45 • iOS 12.1.4 (iPad Air 2)

Share this post


Link to post
Share on other sites

Thanks for the suggestions.

 

When I hold Ctrl nothing happens. I had the task manager open and I noticed that Affinity Photo sat doing nothing in the Background processes until I let go of the Ctrl key and then it disappeared.

 

I haven't installed any fonts recently.

 

 

Share this post


Link to post
Share on other sites

Hi nj36

 

Have you installed and Windows updates at all recently?

 

This could be a .NET issue. Have you restarted your machine at all? I would try uninstalling or repairing. NET if you can or upgrade to 4.7.1 if you haven't already to see if these solve the issues. If not can you try uninstalling and re-installing the Affinity apps

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Hi @Chris_K

 

It is possible that there has been a Windows update in the past fortnight.

 

I tried to install .NET 4.7.1 but it says that this is already installed. I just tried uninstalling the Affinity apps, restarted my machine then reinstalled them with the same result. I see them appear in my background processes in task manager before disappearing and not opening.

 

I also ran the Microsoft .NET Framework Repair Tool.

 

 

Share this post


Link to post
Share on other sites
1 hour ago, nj36 said:

I decided the fastest way to resolve this was to do a fresh install of windows.

 

Ouch! Glad you’ve got the apps working now, anyway.


Alfred online2long.gif
Affinity Designer 1.6.5.123 • Affinity Photo 1.6.5.123 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.6.11.85 • Affinity Designer for iPad 1.6.4.45 • iOS 12.1.4 (iPad Air 2)

Share this post


Link to post
Share on other sites

Damn.... I'm at the "wipe out everything and reinstall Windows" stage too so no help in this thread either. I've tried everything here. It's pretty bad that the program keeps doing this and people have to go to such lengths just to get it to open

Share this post


Link to post
Share on other sites

Hey Gabe

No I dont. Thanks for the suggestion tho. I still havent resolved it. Stuck at reinstall windows but don't really want to do that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×