Jump to content
lluuiiss

Crash on create/edit Text Style

Recommended Posts

I can confirm that this bug is repeatable.

 

I will add it crashes for me when clicking into any of the search fields (ie, swatches, Glyph browser, Assets, media browser).

 

10.13.3

Model Name:    MacBook Pro

Model Identifier:    MacBookPro14,3

Processor Name:    Intel Core i7

Processor Speed:    3.1 GHz

Number of Processors:    1

Total Number of Cores:    4

 L2 Cache (per Core):    256 KB

 L3 Cache:    8 MB

 Memory:    16 GB

Intel HD Graphics 630

Radeon Pro 560

Share this post


Link to post
Share on other sites

Hey guys, welcome to the Affinity Forums.

I'm struggling to reproduce this crash. I know @xman was getting another crash I cannot reproduce in the Guides Manager.  @lluuiiss can you try and reproduce the crash xman is getting whereby going to View > Guides Manager > Add a Horizontal or Vertical guide and then double click the value to edit the guide.

 

You can try doing a soft reset; hold down ctrl when you launch the app and click Clear when prompted.

Share this post


Link to post
Share on other sites

Hey @Chris B, thanks. I was able to reproduce the bug mentioned, as soon as a new guide is added and I attempt to modify its value by clicking, AD crashes. Did a soft reset also without any improvement on guides nor text styles.

Also, as mentioned by @xman, AD is crashing on my side at any attempt to use search fields.

Share this post


Link to post
Share on other sites

Okay, so you've got something in common that I clearly don't. All your app defaults have been set so I can't imagine it is a setting and I assume it has returned to using your GPU and not Software rendering from Preferences > Performance > Display.

 

It sounds like the crash is going to happen wherever a caret cursor is going to placed, where you're about to type something. What input method are you using?

 

 

Share this post


Link to post
Share on other sites

Your hypothesis seems correct @Chris B, the only difference being on editing the Text Styles (as there is no direct action from user but selection on style's name happen by default when dialog opens).

What do you mean by input method?

Share this post


Link to post
Share on other sites

Hey @Chris B,

 

So after posting the issue my screen was showing some artifacts in some areas. So I restarted the machine and the issue seem to resolve it self.

 

@lluuiiss I have your try simply restarting?

 

The day when this happen I had the program open all day only using it sometimes. Jumping from GPU to CPU for different stuff. So what ever is causing this it might be a shared lib/ext or something since it was effecting AP exactly the same.

 

I'll report back if it happens again.

 

Well that didn't take long :(. So before I completed this post I tried it again, and sadly it started again. So it seem the restarting maybe temporary.

 

@Chris B, maybe leave AD/AP open on a machine all day, but force or make the GPU to cpu switch a few times. Put the machine to sleep the try again. Anyway I'm no programmer, but seem like it's some in a temp folder/file that maybe gets corrupt or blocked.

 

An added note I do have SIP turn off while I'm getting my machine to production setup. Not sure if that has any effect on this.

 

Can't start right now, but will look further into this when I get a chance.

 

Thanks

Share this post


Link to post
Share on other sites

@lluuiiss - Thanks! I tried switching to that and it didn't make a difference. Dev didn't find much with your crash report but if I can get one from @xman we might be able to find something common.

 

My Mac pretty much gets restarted once a week on a Friday. I generally leave it on with the apps open all of the time.

Share this post


Link to post
Share on other sites

I've seen someone tweet this morning that macOS 10.13.3 was getting this crash. It seems that a few of you were also on that macOS version. I'm on 10.13.4 so I wonder if this is why I cannot reproduce it? @xman can you attach a crash report for me please as I've got some interest from development. Thanks! 

Share this post


Link to post
Share on other sites

@Chris B Here is a zip with all the crashes for affinity designer & photo. I also sent you a DM.

 

So far designer is not crashing when I try any of the search or guide issues. But trying to work so not really trying at the moment.

crash_reports.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×