Jump to content
MacGB

"Edit in Affinity Photo" using extensions in Photo's not working

Recommended Posts

Very pleased with Affinity Photo. I guess, learning to work with it, I stumbled into a minor problem or bug. I am using Apple Photo's vs 3 as my DAM an High Sierra 10.13.4.

When I try to use the extension showing up as "Edit in Affinity Photo" It returns a thumbnail of the picture and the message "Affinity Photo could not be launched.Please press cancel"(see screenshot). All other Affinity extensions work fine. The strange thing is that when I use the Apple Photo's function "Edit with" (by richt-clicking a picture and then choose Affinity Photo) it launches Affinity Photo as it should. 

Is this a bug or did I miss a setting.

Thanks

Ben

Schermafbeelding 2018-04-19 om 20.09.23.jpg

Share this post


Link to post
Share on other sites

Hi MacGB

 

this is a known issue. High Sierra promotes the edit with option on the right click more than the extensions, which is two different processes, so it is best to use that option for the moment

 

Thanks


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Thanks Chris for the quick respons and info.

 

Perhaps as an inspiration for your development team: Graphic converter 10 has a similar option that still works that way, as does the "External editor for Photos" extension  (App.store).

 

Please consider this as a positive comment ;). Your software is great and I much appreciate it.

Ben

Share this post


Link to post
Share on other sites

Thanks for the suggestion.

I installed the Affinity photo app. at the root level in the Application folder from start, so I guess that cannot be the cause of the problem. 

Some extra info that might help you (I'm not a techie expert).

1. I work in two environments- a day to day user environment and a system-control environment. I didn't fire-up Affinity Photo in the system-control environment ( so entering licence key), I only use that for installing programs and system maintenance. I fired up Affinty in my user environment and entered the license key there

2. I installed the NIK-plug-in collection (as demonstrated in one of your video-tutorials). The plug-in's reside in my day-to day user environment. (They do work though with Affinity Photo, so that seems ok).

3. As I mentioned earlier the other Affinity extensions do work fine and using the "edit with" from the Photos app works o.k. as well so using tha I can fire up Affinity Photo and edited photo's are correctly written back.

Share this post


Link to post
Share on other sites

Hi,
Same difficulty around here.
It happened after the upgrade to Catalina MacOs.

I already uninstalled and reinstalled AffinityPphoto and it didn't work

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.