Jump to content
SavanahNF44

LUT makes app crash

Recommended Posts

I have tried to use luts by going to adjustments and importing the lut from my files but every time I try to click on the lut, the app instantly crashes. I have seen other posts for this problem and it says it has been fixed but my app still crashes. Please help!

Share this post


Link to post
Share on other sites

While MEB is checking your LUT have a look at this collection. They work on my iPad and have some great effects.

 


IPad Pro 10.5 512GB iOS 12.3.1 Affinity Photo 1.7.2.150 Affinity Design 1.7.2.4 Publisher for iPad ?

Share this post


Link to post
Share on other sites
10 hours ago, MEB said:

Hi SavanahNF44,

Welcome to Affinity Forums :)

Do you mind uploading the LUT file for us to check it here please? You can use this link to upload it to us. All files will be deleted after being inspected. Thanks.

 

I just submitted it. I’ve tried all kinds of different ones and they all crash the app. But I submitted one of them. Thanks for your help!

Share this post


Link to post
Share on other sites
9 hours ago, DM1 said:

While MEB is checking your LUT have a look at this collection. They work on my iPad and have some great effects.

 

Hi! Thanks for your help but I just tried out this one and it made my app crash as well. I’m so confused!I have a brand new iPad Pro that I’m editing on with 512gb so I know my iPad isn’t the problem. Hope I can get this worked out soon. 

Share this post


Link to post
Share on other sites

That is strange behaviour. I just loaded one of those  Haldclut LUTs and it worked fine here. Also iPad Pro 512GB.

 

I save my LUT files locally on the iPad. (Documents by Readdle (free) is useful here as I can create orderly named folders and access them from Affinity Photo using import or open from Cloud, or in the case of loading a LUT, Load file opens iOS Files app which accesses the Documents folders directly). Sorry for digressing. 9_9

 

Does your iPad crash if you start a new file and load a LUT?

Try this test - Create a new file. Add a pixel layer and load a Haldclut LUT using the LUT filter and Load file method? I suggest the Haldclut LUT as it is working on my iPad.

Does your iPad still crash?

If not it may be your original .afphoto file is corrupted. You could try Save as, untick Save history and then load the saved file. This has fixed corrupted files in the past.


IPad Pro 10.5 512GB iOS 12.3.1 Affinity Photo 1.7.2.150 Affinity Design 1.7.2.4 Publisher for iPad ?

Share this post


Link to post
Share on other sites

Hi SavanahNF44,

Thank you for the file. This is not a LUT file (.3dl, .csp, .cube, .look formats) but a tone map preset (.aftonemap files). Currently it's not possible to import them on the iPad version - only on the desktop version clicking on the small menu icon on the top right of the Presets panel and selecting Import Presets... when you are in the Tone Mapping Persona. Hopefully this will be added in a future update to the iPad version as well.

 

The application is crashing because you are opening this file from the Load button on bottom (context toolbar) when you apply a LUT adjustment which the program isn't expecting/recognising. I will log this to prevent the program to crash/import .aftonemap files from here. Thanks for bringing this to our attention.

Share this post


Link to post
Share on other sites

@SavanahNF44 The LUT files should end in .cube

Attached is a working LUT file that you can load directly. Try loading that.

The ones in the link above are zipped (compressed) and have to be unzipped before you can load them.

 

Agfa Ultra Color 100.cube


IPad Pro 10.5 512GB iOS 12.3.1 Affinity Photo 1.7.2.150 Affinity Design 1.7.2.4 Publisher for iPad ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×